
16 Optimizing Web Images

For effective Web publishing, your images 

must strike a good balance between file 

size and display quality. Using Adobe 

Photoshop and Adobe ImageReady, you 

can optimize your images so that they 

have reasonable download times from a 

Web server without losing essential 

details, colors, transparencies, or naviga-

tional elements such as image maps.
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In this lesson, you’ll learn how to do the following: 

• Optimize JPEG and GIF files, and adjust the optimization settings to achieve the 

desired balance between file size and image quality.

• Adjust the amount of dithering applied to an image.

• Define a transparent background for an image.

• Batch-process files to automate the optimization process.

This lesson will take about one and a half hours to complete. The lesson is designed to be 

done in Adobe Photoshop and Adobe ImageReady.

If needed, remove the previous lesson folder from your hard drive, and copy the 

Lessons/Lesson16 folder onto it. As you work on this lesson, you’ll overwrite the start files. 

If you need to restore the start files, copy them from the Adobe Photoshop CS Classroom 

in a Book CD.

Note: Windows 2000 users need to unlock the lesson files before using them. For more infor-

mation, see “Copying the Classroom in a Book files” on page 3.

Optimizing images using Photoshop or ImageReady
Optimizing is the process of selecting format, resolution, and quality settings so that an 

image has the efficiency, visual appeal, and utility for Web browser pages. Simply put, 

it’s balancing file size against good looks. No single collection of settings can maximize 

the efficiency of every kind of image file; optimizing requires human judgment and a 

good eye.

Compression options vary according to the file format used to save the image. You should 

be familiar with the general format types.

• The JPEG format is designed to preserve the broad color range and subtle brightness 

variations of continuous-tone images (such as photographs or images with gradients). 

This format can represent images using millions of colors.

• The GIF format is effective at compressing solid-color images and images with areas of 

repetitive color (such as line art, logos, and illustrations with type). This format uses a 

palette of 256 colors to represent the image, and supports background transparency.
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• The PNG format is effective at compressing solid-color images and preserving sharp 

detail. The PNG-8 format uses a 256-color palette to represent an image; the PNG-24 

format supports 24-bit color (millions of colors). However, many older browser applica-

tions do not support PNG files.

• The WBNG format is the standard format for optimizing images for mobile devices, 

such as cell phones. WBMP supports 1-bit color, which means that WBMP images 

contain only black and white pixels. 

Note: For information about using PNG and WBNG formats, see Photoshop Help.

Adobe Photoshop and Adobe ImageReady give you an effective range of controls for 

compressing the file size of an image while optimizing its on-screen display quality. You 

can apply a set of optimization settings to a collection of files, a single file, a layer, or a 

slice. 

In this lesson, you’ll optimize and save images in JPEG and GIF formats. In the exercises 

that follow, you’ll work with a set of images designed to be used on a Web site for a ficti-

tious travel organization.

Photoshop (through its Save For Web dialog box) and ImageReady (through its Optimize 

palette) share many of the same capabilities for optimizing images. For example, you 

can use either application to select from a wide array of file formats and settings, to suit 

the goals for your project. You can also use either one to compare side-by-side views of 

different optimized versions of a file. Using optimization features and color palettes 

in either Photoshop or ImageReady, you can maximize color integrity while minimizing 

file size.

Getting started
You’ll do the first part of this lesson in Adobe Photoshop, but it could be done just as 

well in ImageReady. As you begin, you’ll restore the default application settings for 

Adobe Photoshop so that the descriptions in the instruction match the settings in your 

Photoshop work area. 

The lesson revolves around a primary home-page graphic for the fictitious travel 

organization.
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1 Start Adobe Photoshop while holding down Ctrl+Alt+Shift (Windows) or 

Command+Option+Shift (Mac OS) to restore the default preferences. (See “Restoring 

default preferences” on page 4.)

As messages appear, select Yes to confirm that you want to reset preferences, No to defer 

setting up your color monitor, and Close to close the Welcome Screen.

2 Click the File Browser button on the tool options bar to open it.

3 In the File Browser Folders palette, locate and select the Lessons/Lesson16 folder.

Thumbnails of three different Start and End files appear in the thumbnails pane, many of 

which appear to be quite similar.

4 Select—but do not open—the 16Start1.psd thumbnail, so that the thumbnail is 

highlighted and metadata appears in the Metadata palette. 

5 Select the 16End1.jpg thumbnail. Notice that the file size listed in the metadata is 

smaller but the image looks about the same as the 16Start1.psd.

6 One by one, select and preview the other Start and End files in the Lesson16 folder.

7 Double-click the 16Start1.psd file to open it in Photoshop. Close the File Browser by 

clicking either the File Browser button ( ) on the tool options bar twice (once to bring 

it forward and once to close it) or the close button in the File Browser window.
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Optimizing a JPEG image (Photoshop)
In this lesson, you will optimize files in both JPEG and GIF formats. You goal is to set 

optimization selections so that your files are small and efficient but still look great.

Currently, the 16Start1.psd file size is larger than ideal for use on a Web page. You’ll 

compare different file-compression formats to see which one gives you the most 

compression without sacrificing too much image quality.

Using the Save For Web dialog box

The Photoshop Save For Web dialog box shows you different versions of an image side by 

side, using different optimization settings. You can compare versions as you work, 

adjusting optimization settings and examining the differences until you have the best 

possible combination of file size and image quality.

1 With the 16Start1.psd file open and active in Photoshop, choose File > Save for Web.

Note: If the 4-Up tab is not already selected in the image window, select it now.

Photoshop automatically generates three different sets of optimization settings, besides 

the original image. Notice the information listed under each view of the image, including 

the file size and the number of seconds required to download the image. The first pane 

shows the original file. The second, third, and fourth panes show different combinations 

of optimization settings for the image, including the file format (such as GIF or JPEG) 

and color-reduction algorithm (such as Selective, Perceptual, or Web). 

2 In the lower left corner of the Save For Web dialog box, select 300% or higher from the 

Zoom Level pop-up menu so that you can see the details of the image. 

Compare the preset views of the different optimization settings.
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3 Click one of the four images so that the pointer becomes a hand icon, and drag the 

image so that you can see the differences among the optimized views and the original. 

4 Look carefully at the following areas: the text in the lower right corner of the image, the 

area where the top of the mail box sits in contrast against the blue sky, the shadow of the 

rusted door of the large mail box, the embossed area of the rusted mail box, and other 

image details.

Comparing optimized GIF, JPEG, and PNG formats

You can customize any of the three optimized views in the Save For Web dialog box. To 

do this, you select one of the optimized image previews, and then select settings for it on 

the right side of the dialog box. By experimenting with different combinations of settings, 

you can get a good idea of which settings will best suit your purpose. 

Note: As you perform tasks in this lesson, use the zoom controls frequently so that you can get 

an overall impression of the image and then see small details that show you flaws you might 

not notice at smaller enlargements. Don’t wait for the instructions to tell you to zoom in and 

zoom out each time. 

1 Select the optimized preview at the upper right of the Save For Web dialog box.

2 In the Preset pop-up menu on the right side of the dialog box, select GIF 128 Dithered 

(if it is not already selected).
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The information that is listed immediately below the preview changes.

Notice the dark group of pixels around the rust-covered mailbox and in the green square 

background behind the number 4 in the logo.

You’ll use the two bottom versions of the image to compare GIF 128 Dithered optimi-

zation with JPEG and PNG optimization.

3 Click the lower left version of the image to select it, and select the following JPEG 

options, one at a time, on the Preset pop-up menu:

• JPEG Low. Notice that the image details and text are unacceptably choppy. 

• JPEG High.The image quality improves, but the file size more than triples.

JPEG Low JPEG High

• JPEG Medium. At this setting, the image quality is acceptable and the file size is lower 

than either the JPEG High version or the GIF version. 

Note: You can select other intermediate levels of quality for JPEG files by typing or dragging 

the Quality slider option on the right side of the Save For Web dialog box.
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Now that you’ve tried different GIF and JPEG settings, you’ll use the fourth image preview 

to try another format.

4 Select the lower right version of the image, and then use the Preset menu to select 

PNG-8 128 Dithered.

Although this results in a smaller file size than the original image, the image quality is not 

as good as the JPEG Medium version, which also has a smaller file size. Furthermore, 

many older browsers cannot read the PNG format. To make this image compatible with 

older browsers, you will save this file for the Web using the JPEG Medium optimization.

5 Select your JPEG Medium version of the optimized image (in the lower left corner of 

the dialog box), and then select the Progressive check box.

Note: When Progressive is selected, any download of the image occurs in several passes, each 

of which increases the image quality.

The Progressive JPEG download

6 Click Save. In the Save Optimized As dialog box, use the default name 16Start1.jpg, 

and save the file in the same folder as the original Photoshop file.

7 Choose File > Close to close the 16Start1.psd file, and don’t save your changes.
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Optimizing a GIF image
Now, you’ll optimize an image that has been stylized into stretches of flat color; that is, 

areas where the adjacent pixels have identical RGB color values. You’ll optimize this image 

in GIF format and compare the results of different palette and dither settings. Although 

you could do this entire section in Photoshop, you’ll use ImageReady.

Photoshop and ImageReady share many features, but there are certain tasks you can do 

in Photoshop that are not possible in ImageReady, and vice versa. Other tasks are merely 

more appropriately done in one application or the other.

If you have an open file when you jump from one application to the other, the file opens 

in the application to which you jump. If you have more than one file open, only the active 

file opens in the jumped-to application. If no files are open, you can still jump back and 

forth from one application to the other. In all these cases, it’s just a one-click process.

Using a predefined ImageReady workspace

Before you begin working on a new file, you’ll jump from Photoshop to ImageReady. 

Then, you’ll rearrange the work area by selecting one of the predefined workspaces that 

are always available on the ImageReady Workspace submenu.

1 In Photoshop, click the Jump To ImageReady button ( ) at the bottom of the 

toolbox to switch from Photoshop to ImageReady.

Note: If you do not have enough memory to run both applications simultaneously, quit 

Photoshop and then start ImageReady.

2 In ImageReady, choose Window > Workspace > Optimization Palette Locations.
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Only the bare-bones set of palettes needed for optimization tasks remains open in the 

work area: the Optimize palette group and the Color Table palette group, along with the 

toolbox and tool options bar. If you need another palette at some point, you can reopen 

it by selecting it on the Window menu.

Choosing basic optimization settings in ImageReady

Earlier in this lesson, you used Photoshop optimization settings that were integrated into 

the Save For Web dialog box. In ImageReady, the same options appear in the Optimize 

palette. 

1 In ImageReady, choose File > Open, and open the 16Start2.psd file from the 

Lessons/Lesson16 folder.

This image was created in Adobe Illustrator, and then rasterized into Photoshop format. 

The image contains many areas of solid color.

2 Click the 2-Up tab in the image window.

The optimized version of the image is selected on the right side of the window.
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3 In the Preset pop-up menu on the Optimize palette, choose GIF 128 No Dither.

4 If necessary, click the arrow to expand the Color Table options on the Optimize palette, 

and then select Perceptual on the Reduction pop-up menu.
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The status bar at the bottom of the image window displays the view magnification and 

other useful information about the original and optimized versions of the image. 

A. File size and download time of optimized image 
B. File sizes of original and optimized images

You can customize the type of information that appears here.

Selecting a color reduction algorithm

One of the ways to reduce image file size is to reduce the number of colors in the image. Photoshop can 

calculate the most needed colors for you, based on any of several available algorithms. You specify which 

algorithm is to be used by making a selection from the Color Reduction Algorithm menu, which includes the 

following options:

Perceptual Creates a custom color table by giving priority to colors for which the human eye has greater 

sensitivity. 

Selective Creates a color table similar to the Perceptual color table, but favors broad areas of color and the 

preservation of Web colors. This color table usually produces images with the greatest color integrity. Selective 

is the default option.

Adaptive Creates a custom color table by sampling colors from the spectrum appearing most commonly in 

the image. For example, an image with only the colors green and blue produces a color table made up 

primarily of greens and blues. Most images concentrate colors in particular areas of the spectrum.

Web Uses the standard 216-color color table common to the Windows and Mac OS 8-bit (256-color) 

palettes. This system ensures that no browser dither is applied to colors when the image is displayed using 

8-bit color. (This palette is also called the Web-safe palette.) If your image has fewer colors than the total 

specified in the color palette, unused colors are removed. 

Custom Preserves the current color table as a fixed palette that does not update with changes to the image.

Windows or Mac OS Uses the system’s default 8-bit (256-color) color table, which is based on a uniform 

sampling of RGB colors. If your image has fewer colors than the total number specified in the color palette, 

unused colors are removed.

A B
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5 In the status bar, choose Size/Download Time (56.6 Kbps Modem/ISDN) in the 

middle pop-up menu, and then choose Image Dimensions from the pop-up menu on the 

right.

The 56.6 Kbps is usually more common now than 28.8 Kbps. The dimension displays the 

size of the image in pixels, which is important to know when planning how to fit an image 

into a predesigned Web-page template.

About the Color Table

The Color Table palette displays the colors that the currently selected Reduction option uses for the currently 

active file. The count of the colors used in the image is listed at the bottom of the palette with the various 

buttons.

You can resize the palette or use the scroll bar to view all the colors. You can also change how the colors are 

arranged in the palette by clicking the small arrow to open the Color Table palette menu and then selecting 

a sorting method: by hue, luminance, or popularity.

Other symbols on the color swatches themselves indicate a current swatch (if one is selected), whether or not 

a color is locked, and whether or not a color is a Restricted (Web) color. You’ll learn more about recognizing 

and using these features as you progress through this lesson.

Note: In Photoshop, the Color Table is in the Save For Web dialog box. 

Peachpit Press/Scott Design



LESSON 16526
Optimizing Web Images

Controlling dither and reducing colors
You may have noticed that certain areas of the image appear mottled or spotty. This spotty 

appearance results from dithering, the technique used to simulate the appearance of 

colors that are not included in the color palette. For example, a blue color and a yellow 

color may dither in a mosaic pattern to produce the illusion of a green color that is not 

included in the color palette.

When optimizing images, keep in mind the two kinds of dithering that can occur:

• Application dither occurs when ImageReady or Photoshop attempts to simulate colors 

that appear in the original image but not in the optimized color palette you specify. You 

can control the amount of application dither by dragging the Dither slider in the 

Optimize palette.

• Browser dither can occur in addition to application dither. A browser dither occurs 

when a Web browser using an 8-bit (256-color) display simulates colors that appear in the 

optimized image’s color palette but not in the system palette used by the browser. You can 

control the amount of browser dither by shifting selected colors to Web-safe colors in the 

Color Table palette.

Before you do further optimizing, zoom in to 200% or more and compare the transition 

areas between the landscape images and the solid-color background in both the 

optimized version and the unoptimized original version. In the original, the stylized 

photographs fade smoothly into the background. In the optimized version, the shift is 

abrupt and has harsh borders. Also, notice the rainbow-like bands of color of the cloud in 

the upper right area of the canyon image.

Reducing the color palette

To compress the file size further, you can decrease the total number of colors included in 

the Color Table palette. A reduced range of colors will often preserve good image quality 

while dramatically reducing the file space required to store extra colors.

Currently, 128 colors compose the 16Start_2.psd file, as shown in the Colors option in the 

Optimize palette, under Color Table. Your ultimate goal in this entire section is to get that 

number down to 32 without ruining the appearance of the graphic.

1 Make sure that the optimized version of the image is selected and that Perceptual is 

selected in the Optimization palette. Notice the current file sizes.
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2 On the zoom pop-up menu in the bottom of the image window, select 200% or higher, 

or use the Zoom tool ( ) to enlarge your view. Make sure that you zoom in enough so 

that you start to see the pixelation of the image.

3 Using the Hand tool ( ), select the image on the right of the 2-up display, and drag so 

that you can see some of each of the following: the dark shadows in the aspen trees, some 

trees in the rock canyon, and the mountain top with some of the light blue sky to its right.

4 In the Colors option in the Optimize palette, type or select 32 from the pop-up menu.
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Notice the significant reduction in the file size, but that there are problems. The shadows 

between the aspen trees are now dark brown instead of dark green, while the trees in the 

canyon image are dark green instead of brown. The clouds in the brown canyon sky look 

distinctly striped in multiple colors.

5 Reselect 128 as the Colors option.

Obviously, simply reducing the color palette without solving the problems that this 

creates is not a good idea. However, there are some techniques you’ll try next that will 

produce better results.

Adding dither to simulate missing colors

Before you begin this procedure, make sure that the Optimize palette still shows 

Perceptual as the Reduction option and 128 for Colors. In the canyon image, notice the 

gradient brown bands in the cloud. You’ll be focusing on this portion of the image and 

the aspen shadows as you make adjustments in this topic.
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1 Under Dither in the Optimize palette, select Diffusion on the Method pop-up menu 

and drag the Amount slider to 100%.

Now a speckling pattern softens the transition in color in the cloud area. Any change in 

the aspen area is either not noticeable or more subtle.

2 Reselect 32 as the Colors option.

The aspen image looks arguably even worse than before. The area that had been dark 

green now appears as a speckling of dark brown on a medium green. The clouds in the 

canyon area look smoother, but the skies over the canyon and mountain images—both of 

which used to be uniform colors—are now speckled.

3 Drag the Dither slider to 50%, and then experiment with other dither percentages.

ImageReady minimizes the amount of dither in the image, but no percentage of dither 

will preserve the drop shadows without ruining the green background. Also, reducing the 

percentage of dither reintroduces the multicolored striping in the clouds above the 

canyon.

4 Set the dither back to 100%. 

5 Reset the Colors option to 128. (Leave the dither settings as they are.) 
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The aspen shadows turn dark green again and the speckling is not noticeable. But while 

the file size is smaller than the original (unoptimized) version, the optimized version is a 

little larger than it was without dithering. You have more work to do in optimizing this 

file, so go on to the next topic.

For an illustration of the effects of different dither percentages on an image, 

see figure 16-2 in the color section.

Locking colors to preserve image details

In the previous procedures, you saw how reducing the number of colors can compromise 

details in an illustration, even after you add dithering. You’ll now learn how to lock 

specific colors to ensure that those colors do not drop out of the reduced palette.

As you begin this work, make sure that the Optimize palette shows Perceptual, 128 colors, 

and Diffusion dithering set at 100%.

1 In the toolbox, select the Eyedropper tool ( ), and click the darkest green you can find 

in the aspen shadows to sample that color. 

Notice that the dark green now appears in the Foreground Color swatch in the toolbox 

and that the tiny swatch for the dark green in the Color Table is highlighted with a white 

border.

2 Click the Lock button ( ) at the bottom of the Color Table palette to lock the 

selected color of green. 

Locking a color swatch gives that color priority over non-locked colors. If you reduce the 

number of colors from 128 to a lower number, locked colors can’t be bumped from the 

list by non-locked colors. 
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3 In the Optimize palette, change the Colors value back to 32.

Now the green shadows look good, but notice the speckled dithering this introduces into 

the sky area in the brown canyon and the blue mountain portions of the graphic, which 

is starting to look something like a blizzard. Once again, the cayon trees, which should be 

brown, are dark green. Despite this, you shouldn’t abandon the effort.

4 Hold down the spacebar so that the pointer changes from the eyedropper icon to the 

hand icon ( ), and drag the image so that about half the viewing area is covered by the 

canyon image and half by the mountain image.

5 In the Optimize palette, select 128 in the Colors option.

Continue on to the next topic, where you’ll lock more colors until the image achieves an 

acceptable appearance.

Note: You can unlock a locked color by selecting the color swatch in the Color Table and then 

clicking the Lock button again.

Locking more colors to prevent unwanted dithering

The challenge of working with 32 colors is finding the ideal 32 colors. As you saw in the 

previous procedure, correcting an unwanted dithering effect or color shift in one area 

tends to produce other problems in other areas.

Rather than giving up on the locking process, you’ll continue to refine the image by 

locking more colors. You’ll go back and forth between 32 and 128 colors, locking in the 

original colors when the reduction to 32 colors causes unwanted dithering or a change in 

color. Once you’ve locked a color, it’s important to reexamine the entire image carefully, 

to see what kinds of problems that color lock has created. 
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1 Select the Eyedropper tool ( ), and click the dark brown that now appears in the 

center of the trees in the canyon image. Then, click the Lock button ( ) at the bottom of 

the Color Table palette to lock the selected color. 

A small square appears in the lower right corner of the color swatch, indicating that the 

color is locked. 

2 Repeat Step 1 three more times, sampling and locking the following:

• The medium brown sky in the canyon area.

• The dark blue sky to the upper left of the mountain top.

• The light blue sky to the right of the mountain top.

3 Reduce the Colors option to 32.

4 Hold down the spacebar so that the pointer changes to the hand icon ( ), and drag 

the image so that you can see the forested ridge in front of the mountain, the “4,” and 

some of the text in the lower right area of the image.

Now the ridge in the blue image is unacceptably dithered.

5 Change the number of colors back to 128, and use the same technique you used in 

Steps 1 and 2 to lock the dark blue in the ridge. Then change the Colors options to 32. 
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The ridge looks good, but now the khaki-colored text is so dithered that it looks like 

multicolored confetti. Have courage; you’re on the brink of reaching your goal.

6 Change the number of colors back to 128, and use the same technique you used in 

Steps 1 and 2 to lock the text color. Then change the Colors options to 32. 

7 Examine every area of the image to make sure that there are no other color shifts, and 

then choose File > Save.

If you want to do so, you can continue to lock colors, such as the darker color at the center 

of the palm tree or some other color. 

Note: There is some dithering that is unavoidable, such as in areas with gradients. Each of 

the four blocks of color images has a gradient separating the solid-colored background from 

the image it contains. Dithering is the best possible choice for balancing file efficiency and 

acceptable appearance for gradient color changes. 

If you experiment with optimization of image files, you’ll notice that significant image 

degradation can occur when the palette is reduced below 32 colors. In fact, for all but the 

simplest images, even 32 colors may be too drastic a reduction. For the best file 

compression of a GIF image, try to use the fewest number of colors that will still display 

the quality you need.

For an illustration of the image set to different palette values, see figure 16-1 in the 

color section.

Minimizing browser dither

In the Photoshop Save For Web dialog box and in ImageReady, you can view application 

dither directly in an optimized image. You can also preview the additional browser dither 

that will appear in the final image when viewed in a browser using an 8-bit display.

As you learned earlier, images that include non–Web-safe colors undergo a process of 

dithering when displayed in a Web browser using an 8-bit display, because the browser 

simulates colors that do not occur in the 8-bit system palette. From ImageReady, you can 

preview how an optimized image will look when dithered in a Web browser. 

To protect a color from browser dither, you can Web-shift the color, converting the color 

to its nearest equivalent in the Web palette. Because the Web palette includes the subset 

of colors that appear in both the Windows and the Mac OS system palettes, Web palette 

colors will display without dithering in browsers on either platform. 
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1 With the optimized 16Start2.psd image open, choose View > Preview > Browser Dither 

(so that a checkmark appears next to the command).

Notice that browser dither occurs in the sky and the slope of the canyon image, even 

though you locked the medium brown color of the sky earlier in this lesson. You’ll Web-

shift that color to reduce the amount of browser dither in the image.

Note: If you don’t see the dithering, increase the zoom or turn off the browser-dither preview 

and then turn it back on to observe the effects. You can toggle the browser-dither preview off 

and on by pressing Ctrl+Shift+Y (Windows) or Command+Shift+Y (Mac OS). 

2 Switch out of Browser Preview mode, but this time do it by pressing Ctrl+Shift+Y 

(Windows) or Command+Shift+Y (Mac OS). Or, you can use the View > 

Preview >Browser Dither command again.

3 Select the Eyedropper tool ( ) and click anywhere in the canyon sky area. The sampled 

color appears selected in the Color Table palette.

4 Click the Web-shift button ( ) at the bottom of the Color Table palette.

The swatch changes position in the palette and a small diamond appears in the center of 

the swatch, indicating that it has been shifted to its nearest Web-palette equivalent.
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5 Using the same technique, select a sample of the lighter brown on the slope of the 

canyon and click the Web-shift button ( ) again.

6 Choose View > Preview > Browser Dither, or press Ctrl+Shift+Y (Windows) or 

Command+Shift+Y (Mac OS) to preview the file in that mode.

The browser dither is gone from the selected areas and the rest of the image is acceptable.

7 Choose View > Preview > Browser Dither to deselect it, and then choose File > Save.

By Web-shifting the brown background, you changed its color to one that can be 

displayed without dithering by a Web browser on a 256-color system. 

Note: In Photoshop CS and ImageReady CS, you can also quickly map one color to another 

color or to a transparency. This remapping reassigns all the pixels that appeared in the 

selected color to the new color or transparency. For more information, see ImageReady Help.

Optimizing slices

Professional designers often combine various types of graphic resources into a single Photoshop or 

ImageReady image. For example, you might create an image file composed of graphics with large areas of flat 

color and typography, combined with continuous-tone photographs or other images with complex shading 

and graduated fills. It would be difficult to get satisfactory results by optimizing such an image using just a 

single optimization scheme. 

If you divide an image into slices, you can optimize any individual unlinked slices uniquely. For example, you 

could apply GIF optimization to some areas within an image while applying JPEG or PNG optimization to 

others. To do this, you simply select the individual slice (using the Slice Select tool) and set optimization 

options in the Save For Web dialog box (Photoshop) or Optimize palette (ImageReady).
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Specifying background transparency
You can use background transparency to place a nonrectangular graphic object against 

the background of a Web page; the areas outside the borders of the object are defined as 

transparent, letting the Web-page background color show through. You can specify 

background transparency for GIF and PNG images.

Converting the Background into an ordinary layer

Before you can use the GIF file format’s ability to preserve transparency, you must create 

some transparency in your image. You’ll do that by removing the white backdrop 

surrounding the image. To start this process, you’ll first convert the Background layer to 

a regular layer, because a Background layer is always locked and cannot have any trans-

parency. 

1 Make sure that the 16Start2.psd file is open in ImageReady.

2 Select the original (left) version of the image in the image window.

3 Choose Fit on Screen from the Zoom Level menu in the lower left corner of the image 

window.

4 Choose Window > Layers to open the Layers palette, and then open the Layers palette 

menu and choose Layer Options.
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5 Click OK to close the Layer Options dialog box without changing the default settings 

(including the name, Layer 0). The layer now appears in the Layer palette as Layer 0. 

A Background layer cannot contain any transparency information because, by definition, 

there is nothing behind it to be seen. If you tried to use one of the techniques that usually 

can replace colored pixels with transparent ones, the results would be that the original 

pixels would be changed to the currently selected background color instead of becoming 

transparent pixels.

Using the Magic Eraser tool to create transparency

In this part of the lesson, you’ll use the Magic Eraser tool to quickly convert the white 

backdrop behind the images and lettering to transparent pixels.

However, you don’t want to erase any white pixels that might appear inside the colored 

images themselves. You’ll accomplish this in two phases. 

1 Make sure that the original (left) version of the image is selected in the image window. 

You can erase background pixels only in the unoptimized version, not in an optimized 

version.

2 Select the Magic Eraser tool ( ), which may be hidden under the Eraser tool ( ).

3 In the tool options bar, make sure that the Contiguous check box is selected.
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4 Click the white background that surrounds the color images.

The checkerboard pattern replaces the white background, indicating that the area is 

transparent. 

5 Click the rectangular white area that is trapped within the middle of the four colored 

blocks.

Now most of the white backdrop is erased, except for the small islands of white pixels in 

the closed areas of the lettering.
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Converting isolated areas of white into transparency

The Magic Eraser tool did not remove the white areas that are isolated within enclosed 

areas of the lettering because the Contiguous option was selected in the tool options bar. 

One way to correct this would be to zoom in further and click in each of the white areas 

within the letters, just like you clicked the white rectangle in the center of the image. 

Instead, you’ll use a method that works much more efficiently in cases where there may 

be a large number of small, discontiguous areas that you want to erase, while preserving 

other areas of similarly colored pixels that you do not want to erase.

1 In the tool options bar for the Magic Eraser tool ( ), deselect the Contiguous option.

2 Select the Rectangular Marquee tool ( ), and carefully draw a rectangular selection 

marquee around the word “Corners” in the Original (left) version of the image.
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3 Hold down Shift so that a small plus symbol appears in the pointer-icon crosshairs, and 

drag another selection rectangle around the word “Travel” and the word “of.” The two 

selected areas merge into one selection shape. (You can do the word “of” separately, if you 

prefer by holding down Shift and dragging to add it to the selection. Or, you can either 

include a bit of the yellow block when you select both “Travel” and “of.”)

4 Select the Zoom tool ( ), and zoom in so that you can easily see the areas within the 

selection (about 300%). 

5 Select the Magic Eraser tool ( ), and then carefully click the white background inside 

the letter “O.”

The white pixels within the letter “O” are converted to transparent pixels, but so are the 

pixels inside the “A” and “R” characters in “Travel” and the “O” in “of.”

6 Choose Select > Deselect, and then choose File > Save.
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Finalizing the Color Table

Although it’s not usual to think of transparency as a color, it does count as one of the 32 

colors in the Color Table for the image. That means you need to inspect the image one 

more time to find any unacceptable dithering caused by the shift to transparency.

1 Scroll, or select the Hand tool ( ) and drag, to examine all the areas of the image. 

Notice that there is now heavy dithering in the green around the aspen trees.

2 Select the optimized version on the right side of the image window.

3 In the Color option on the Optimize palette, select 128.

4 Select the Eyedropper tool and click the medium green in the upper right corner of the 

aspen image. 

5 In the Color Table palette, click the lock icon to lock the color.

6 In the Optimize palette, select 32 as the number of colors.

7 Scroll or use the Hand tool ( ) to examine the image one more time, confirming that 

the image strikes an acceptable balance between dithering and file size. Then choose 

File > Save.
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Previewing transparency

Now you will preview the transparency in your browser. Because the ImageReady preview 

feature displays the image on a Web page with a white background, you’ll change the 

matte color of the image so that you can see the transparency.

1 In the image window, select the optimized (right) version of the image.

2 On the Optimize palette, make sure that the Transparency check box is selected. 

Selecting Transparency converts areas in the original image with less than 50% opacity to 

background transparency in the optimized image. 

3 Click the Matte swatch in the Optimize palette to open the color picker, and then select 

any color except white. Click OK to close the color picker.

Peachpit Press/Scott Design



543ADOBE PHOTOSHOP CS
Classroom in a Book

4 Choose File > Preview In, and choose a Web browser from the submenu.

Note: To use the Preview In command, you must have a Web browser installed on 

your system.

If it is not already open, the browser first starts and then displays the optimized image in 

the upper left corner of the browser window. The browser also displays the pixel dimen-

sions, file size, file format, and optimization settings for the image, along with the HTML 

code used to create the preview.

Transparency option selected Transparency option deselected

5 Quit your browser when you’re finished previewing the image.
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Trimming extra background areas

Although the background of the image for the fictitious travel organization now contains 

transparent pixels that do not display, these pixels still take up file space, adding to the size 

of the image. You can trim away unneeded background areas to improve the layout of the 

image and optimize the file size.

1 In ImageReady, choose Image > Trim.

You use the Trim command to crop your image according to the transparency or pixel 

color of the extra border area.

2 In the Trim dialog box, select Transparent Pixels if it is not already selected, and 

click OK.

ImageReady trims the extra transparent areas from the image.

3 Choose File > Save Optimized As. 

4 In the Save Optimized As dialog box, use the default name (16Start2.gif), and 

click Save. 

5 In the Replace Files dialog box, click Replace (if it appears).

6 Choose File > Close.

You will be prompted to save the 16Start2.psd file before closing. Since you are finished 

with this file for this lesson, there is no need to save the last changes.
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Creating a dithered transparency
In this section of Lesson 16, you’ll create a dithered transparency for a graphic that will be 

used in another area of the Web site for the fictitious travel organization. By creating a 

dither from an opaque drop shadow to transparency, you’ll make it possible to create a 

smooth transition from the image to any color backdrop on the page without having to 

redo any work.

You’ll do this in two procedures. First, you’ll apply a drop shadow to the image. Then, 

you’ll add dithering to the drop shadow so that it blends into a background color for the 

Web page.

You can do this procedure in Photoshop or in ImageReady, using the same controls but 

in slightly different locations.

Adding a drop shadow

The file you’ll be working on is intended to serve as a graphic that users click to open 

another page on the Web site. You’ll add a drop shadow to the button to make the image 

appear to float above the background, emphasizing that it is an interactive element of the 

page.

1 Choose File > Open, and select the 16Start3.psd file in the Lessons/Lesson16 folder.

2 If necessary, choose Window > Layers to open the Layers palette, and then select 

Layer 1, if it is not already selected.

3 Select the Add A Layer Style button ( ) at the bottom of the Layers palette, and then 

select Drop Shadow from the pop-up menu.

4 In the Layer Style dialog box, enter the following values:

• For Opacity, drag the slider or type 65%.

• For Distance, drag the slider or type 15 px.

• For Spread, drag the slider or type 10%.

• For Size, drag the slider or type 15 px.
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5 Click OK to close the Drop Shadow dialog box.

6 Choose File > Save.

Adding transparency dithering to the drop shadow

As you’ve already learned, dithering is a method of creating gradations of color with a 

limited color palette. This makes it useful for Web pages, because you can simulate 

smoother gradations without sacrificing small file size and quick downloads.

1 (Photoshop only) With the 16Start3.psd active, choose File > Save For Web to open the 

Save For Web dialog box. 

This step is not necessary in ImageReady.

2 Click the Optimized tab in the Save For Web dialog box (Photoshop) or image window 

(ImageReady), and then set the following options on the right side of the Save For Web 

dialog box (Photoshop) or the Optimize palette (ImageReady):

• In the Preset pop-up menu, select GIF 128 Dithered.

• Select the Transparency check box, if it is not already selected. 

• In the Dither pop-up menu for Transparency, select Diffusion.
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• In the Amount option, use the pop-up slider or type 64%. 

Save For Web dialog box Optimize palette
(Photoshop) (ImageReady)

3 Click the Matte swatch to open the color picker. Select any color other than white, and 

click OK. (We selected R=250, G=234, B=212, a neutral beige to set off the blues in the 

mailbox photograph.)

To see the effect of the matte setting, try zooming in so that you can see individual 

pixels in the dither—about 400% or even all the way to 1600%, which is the maximum. 

Notice that the pixels closest to the edge of the mailbox and blue frame area are dark, and 

that the others become increasing more blended with the matte color as they occur 

farther from the edge. Then zoom back to 100%.
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4 Do one of the following:

• (In Photoshop) At the bottom of the Save For Web dialog box, click the button with the 

browser icon, or click the arrow to select your browser from the pop-up menu. 

• (In ImageReady) Use the Preview In Default Browser button or the Preview In 

submenu on the File menu to open the file in a browser.

5 In the browser, notice how the drop shadow blends into the background matte color. 

When you finish viewing your document, close the browser or go back to Photoshop or 

ImageReady. 

6 Click the Save button in the Save For Web dialog box (Photoshop) or choose File > 

Save Optimized (ImageReady).

7 In the Save Optimized dialog box, accept the default settings and filename 

(16Start3.gif) and save the file in your Lessons/Lesson16 folder. 

8 Choose File > Save to save the 16Start3.psd file, or close the file without saving.
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Batch-processing file optimization
ImageReady supports batch processing through the use of droplets—icons that contain 

actions for ImageReady to perform on one or more files. Droplets are easy to create and 

use. To create a droplet, you drag the droplet icon out of the Optimize palette and onto 

the desktop. To use it, you drag a file or folder over the droplet icon on the desktop.

1 In ImageReady, choose File > Open, and open any file in the Lessons/Lesson16/Desti-

nations folder.

2 Experiment with different file formats and other settings in the Optimize palette as 

desired until you are satisfied with the result. (We used JPEG for Format, High (60) for 

Quality, and the Progressive option.)

3 Drag the droplet icon ( ) out of the Optimize palette and drop it anywhere on your 

desktop. (If you are using Windows, you may have to resize the ImageReady window to 

make your desktop visible.)

4 Close the file (without saving it).

5 From your desktop, drag the Destinations folder from the Lessons/Lesson16 folder and 

drop it onto the droplet to batch-process the photographic images within the folder.

ImageReady optimizes each file and adds the Web image to the Destinations folder.

6 In ImageReady, open any or all of the JPEG image files in the Destinations folder. 

Notice that they have all been optimized according to the settings specified when the 

droplet was created.

7 Quit ImageReady. You have now finished this project and this lesson.
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Review questions
1 For image optimization, what are the advantages of using ImageReady rather than 

Photoshop?

2 What is a color table?

3 When does browser dither occur, and how can you minimize the amount of browser 

dither in an image?

4 What is the purpose of assigning matte color to a GIF image?

Review answers
1 There aren’t really any advantages to using one application over the other for 

optimization. Both Photoshop and ImageReady can perform a wide range of image-

optimization tasks. ImageReady has many Web-specific features that you won’t find in 

Photoshop, but image optimization is not one of them.

2 A color table is a table that contains the colors used in an 8-bit image. You can select 

a color table for GIF and PNG-8 images, and add, delete, and modify colors in the 

color table.

3 Browser dither occurs when a Web browser simulates colors that appear in the image’s 

color palette but not in the browser’s display system. To protect a color from browser 

dither, you can select the color in the Color Table palette, and then click the Web-shift 

button at the bottom of the palette to shift the color to its closest equivalent in the Web 

palette. 

4 By specifying a matte color, you can blend partially transparent pixels in an image with 

the background color of your Web page. With matting, you can create GIF images with 

feathered or anti-aliased edges that blend smoothly into the background color of your 

Web page. You can also specify a dither to transparency.
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