
15 Adding Interactive Slices and 
Rollovers

Slices are divisions of an image area that 

you can define using Adobe Photoshop or 

Adobe ImageReady. You can animate 

your slices, link them to URL addresses, 

and use them for rollover buttons. 

Another practical use of slices is to opti-

mize them individually in different Web 

image formats to maximize the effective-

ness of your Web images while minimiz-

ing download times.
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In this lesson, you’ll learn how to do the following: 

• Create image slices, using four different methods.

• Optimize individual image slices using various settings and file formats.

• Create “no image” slices to contain text and HTML.

• Create rollover buttons.

• Apply a warped text style to a text layer.

• Create Over, Down, and Selected rollover states for slices.

• Specify different combinations of hidden and visible layers as the designated conditions 

of various rollover states.

• Generate an HTML page that contains the sliced image in a table.

This lesson will take about 90 minutes to complete. The lesson is designed to be done in 

Adobe Photoshop and Adobe ImageReady. Some sections must be done in ImageReady.

If needed, remove the previous lesson folder from your hard drive, and copy the Lesson15 

folder onto it. As you work on this lesson, you’ll overwrite the start files. If you need to 

restore the start files, copy them from the Adobe Photoshop 7.0 Classroom in a Book CD.

Note: Windows users need to unlock the lesson files before using them. For more information, 

see “Copying the Classroom in a Book files” on page 4.
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Getting started
Before beginning this lesson, restore the default application settings for Adobe Photoshop 

and Adobe ImageReady. See “Restoring default preferences” on page 5.

You’ll start the lesson by viewing an example of the finished HTML banner that you’ll 

create. The banner graphics react to your actions with the mouse. For example the image 

changes appearance when the pointer “rolls over” some areas or you click those areas.

1 Start a Web browser, and open the end file Banner.html from the Lessons/Lesson15/ 

15End/Architech Pages folder.

The file contains an HTML table that links to several Web images all created from 

Photoshop and ImageReady slices. 

2 Move the mouse pointer over the “designs,” “structures,” “art,” and “contact” buttons 

in the banner.

Notice the small graphics that appear to the left of the buttons when you move the pointer 

over the first three buttons. Also notice the change in the word Architech when you move 

the pointer over the last button.

3 Hold down the mouse button and drag the pointer over the first three buttons, 

noticing how the word Architech changes this time. Release the mouse button.

4 Move the pointer over the large blue circle near the center of the image and let it hover 

until you see a pop-up text box with additional information. Then click the blue circle to 

go to the Team page.

5 On the Team page, try rolling the pointer over the three different buttons and notice 

the changes. Try clicking each button, and then click the Team button. Notice the changes.
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If you want to go back to the banner page, use the Back button on your browser. 

6 When you’re done viewing the end file, close it and quit the browser.

About slices
Slices are areas in an image that you define based on layers, guides, or precise selections 

in the image, or by using the slice tool. When you define slices in an image, Photoshop or 

ImageReady creates an HTML table or cascading style sheet to contain and align the 

slices. If you want, you can generate an HTML file that contains the sliced image along 

with the table or cascading style sheet. 

You can optimize slices as individual Web images, add HTML and text to slices, 

and link slices to URL addresses. In ImageReady, you can animate slices and create 

rollovers with them.

In this lesson, you’ll explore different ways to slice an image in Photoshop and 

ImageReady, optimize the slices, and create four rollover buttons for the banner. 

To learn how to animate slices, see Lesson 16, “Creating Animated Images for the Web.”

Slicing an image in Photoshop
Adobe Photoshop lets you define slices using the slice tool or by converting layers into 

slices. You’ll begin the lesson by slicing parts of a banner image for buttons using the slice 

tool in Photoshop. You’ll name the slices and link them to URL addresses, and then 

optimize the slices. Then you’ll continue slicing the banner image in ImageReady and 

create rollovers for the button slices.

About designing Web pages with Photoshop and ImageReady

When designing Web pages using Adobe Photoshop and Adobe ImageReady, keep in mind the tools and 

features that are available in each application. 

• Photoshop provides tools for creating and manipulating static images for use on the Web. You can divide 

an image into slices, add links and HTML text, optimize the slices, and save the image as a Web page.

• ImageReady provides many of the same image-editing tools as Photoshop. In addition, it includes tools and 

palettes for advanced Web processing and creating dynamic Web images such as animations and rollovers.

–From Adobe Photoshop 7.0 online Help
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Experimenting with slices in Photoshop

In this procedure, you’ll learn not only some of the ways you can create slices, but also the 

difference between use slices and auto slices. User slices and auto slices also have different 

capabilities, which is the reason that it is important to understand the distinctions 

between them. 

• User slices are areas that you actively designate as slices. 

• Auto slices are the rectangular divisions of the remainder of the image—all the areas 

that are outside of a user slice. Photoshop and ImageReady create these slices for you.

1 Start Adobe Photoshop.

If a notice appears asking whether you want to customize your color settings, click No.

2 Choose File > New, and then click OK to accept the default settings.

3 Choose View > Show > Slices so that a checkmark appears on the Slices command.

4 In the toolbox, select the slice tool ( ) , and then drag a small rectangle anywhere 

inside the image window. You have just created a user slice.

Notice that the rectangle is selected (borders are highlighted and handles are visible). 

Also, notice that there are other slices, which are identified by a differently colored label. 

These other slices are the auto slices. Each slice is numbered. 
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5 Create another user slice by dragging the slice tool in another area of the image 

window.

Slices are numbered sequentially, moving from top to bottom and left to right across the 

image. When you define a new user slice, all the slices in the image are renumbered.

6 In the toolbox, select the slice select tool ( ) hidden under the slice tool, and try the 

following:

• Select one of the user slices you drew. Drag it to another position. Then drag one of the 

anchor points to resize the slice.

• Select one of the auto slices. Then try dragging or resizing it.

Although you can select both user slices and auto slices, you can drag and resize only user 

slices. Auto slices do not have selection handles. 

7 Select one of the larger slices (either a user slice or an auto slice), and then go to the tool 

options bar and try the following actions:
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• Click the Hide Auto Slices button. Then click it again (as the Show Auto Slices button).

• Click the Slice Options button and examine the options available in the Slice Options 

dialog box. Click Cancel to close the dialog box. You’ll do more work with this shortly.

• Click the Divide Slice button, and then make sure that the Preview button is selected in 

the dialog box and that you can see the entire selected slice in the image window. Then, 

in the dialog box, select the Divide Horizontally Into check box and enter a number 

greater than one for the number of evenly spaced slices you want to create. Notice the 

results. Repeat for the Divide Vertically Into option. When you finish experimenting, 

close the dialog box.

Note: In ImageReady, choose Slices > Divide Slice to do this procedure.

8 Choose File > Close, and do not save your changes.
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Using the slice tool to create slices

Now that you’ve had a taste of how slices work, you’ll start making changes to the sample 

project for this lesson. Using the slice tool, you’ll define four user slices for buttons in the 

banner.

1 Choose File > Open, and open the file 15Start.psd from the Lessons/Lesson15/15Start 

folder.

If a notice appears asking whether you want to update the text layers for vector-based 

output, click Update.

The lesson file includes blue horizontal and vertical guide lines. You’ll use the guides and 

the snap-to commands when you draw marquees, so that they are tightly aligned.

2 Choose View > Show > and make sure that both Guides and Slices are selected 

(checked). 

3 Choose View > Snap To > Guides, and then choose View > Snap To > Slices to select 

(place checkmarks on) both of these commands.

Types of slices

Slices you create using the slice tool are called user slices; slices you create from a layer are called layer-based 

slices. When you create a new user slice or layer-based slice, additional auto slices are generated to account 

for the remaining areas of the image. In other words, auto slices fill the space in the image that is not defined 

by user slices or layer-based slices. Auto slices are regenerated every time you add or edit user slices or layer-

based slices. 

User slices, layer-based slices, and auto slices look different—user slices and layer-based slices are defined by 

a solid line, while auto slices are defined by a dotted line. In addition, each type of slice displays a distinct 

icon. You can choose to show or hide auto slices, which makes your work with user and layer-based slices 

easier to view.

A subslice is a type of auto slice that is generated when you create overlapping slices. Subslices indicate how 

the image will be divided when you save the optimized file. Although subslices are numbered and display a 

slice symbol, you cannot select or edit them separately from the underlying slice. Subslices are regenerated 

every time you rearrange the stacking order of slices.

–From Adobe Photoshop 7.0 online Help



463ADOBE PHOTOSHOP 7.0
Classroom in a Book

4 Select the slice tool ( ), and draw a marquee around the rectangular area containing 

the word designs.

5 One at a time, draw slice marquees around each of the other words in the same row: 

around the words structures, art, and contact to create slices for three more buttons.

Make sure that there are no gaps between the slices, because gaps would become auto 

slices. (If necessary, use the zoom tool ( ) to get a closer view, and then double-click the 

zoom tool to return to 100%.)

You can change the way the pointer appears on-screen for the slice tool by changing 

your Photoshop preferences. To change the slice tool’s standard pointer ( ) to the precise 

pointer ( ), choose Edit > Preferences > Display & Cursors (Windows, Mac OS 9) or 

Photoshop > Preferences > Display & Cursors (Mac OS 10), select Precise for Other Cursors, 

and click OK.

If you need to resize a slice, select the slice select tool ( ) hidden behind the slice tool, 

select the slice, and drag the selection handles. 

6 Choose File > Save to save your work.

Setting options for slices in Photoshop

Before optimizing slices as Web images, you can set options for them, such as naming the 

slices or assigning URL links to them. The names you assign to the slices determine the 

filenames of the optimized images. 

For the four user slices that you defined earlier, you’ll name them, link them to other Web 

pages, and specify target frames.

Note: Setting options for an auto slice automatically promotes it to a user slice.
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1 Select the slice select tool ( ), and use it to select the Designs slice.

2 In the tool options bar, click the Slice Options button.

By default, Photoshop names each slice based on the filename and the slice number, so 

the current filename appears as “15Start_03,” representing slice number three in the 

15Start.psd file.

3 In the Slice Options dialog box, enter the following information: In Name, type 

Designs_button; in URL, type Designs.html; and in Target, type _blank. Then click OK.

Note: The Target option controls how a linked file opens when you click the link, such as 

whether the file opens in a new browser window or replaces the currently displayed file in the 

open browser. For more information, see Adobe Photoshop 7.0 online Help or an HTML 

reference (either printed or available on the Web).
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4 Enter information for the other three user slices you created:

• Select the Structures slice and type Structures_button in Name, Structures.html in 

URL, and _blank in Target.

• Select the Art slice, and type Art_button in Name, Art.html in URL, and _blank in 

Target.

• Select the Contact slice and type Contact_button in Name, Contact.html in URL, and 

_blank in Target.

5 Choose File > Save.

In the Slice Options dialog box, you can also enter message text to appear in the browser’s 

status area, enter alternate text to appear in place of the images if they don’t appear in the 

browser, specify dimensions to move or resize a slice, and change the slice to a No Image 

slice that contains HTML and text. Additional output settings for changing the 

background color of a slice are available when you open the Slice Options dialog box from 

the Save For Web dialog box or Save Optimized dialog box.

Optimizing slices in Photoshop

You can use Photoshop slices to optimize individual areas of the image, which is useful 

when some areas of the image require greater resolution or settings than the rest of the 

image. You optimize one or more slices by selecting them in the Save For Web dialog box, 

choosing optimization settings, and saving optimized files for either the selected slices or 

all slices. Photoshop creates an Images folder to contain the optimized files.

Next, you’ll optimize the four user slices you defined.

1 Choose File > Save for Web.

2 On the left side of the Save For Web dialog box, select the slice select tool ( ).

3 In the optimized version of the image, Shift-click to select the four slices you created.
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4 On the Settings pop-up menu, choose GIF Web Palette, and then click Save.

5 In the Save Optimized As dialog box, do the following:

• On the Format pop-up menu, choose Images Only.

• On the Slices pop-up menu, choose Selected Slices.

• Select the Lessons/Lesson15/15Start/Architech Pages folder as the location for the 

saved file.

• Leave the name setting as it is (15Start.gif), and click Save.

Photoshop saves the optimized images in an Images folder within the Architech Pages 

folder and uses the names you specified in the Slice Options dialog box for the filenames. 

If there are any gaps in the table, Photoshop creates a Spacer.gif file.

6 Choose File > Save.
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Slicing the image in ImageReady
You’ve already learned several ways to create and work with slices in Photoshop, all of 

which can also be done in ImageReady. Although the options sometimes appear in 

different locations in the two applications, you can also use either Photoshop or 

ImageReady to create slices from guides or layers and to optimize individual slices.

In this part of the lesson, you’ll use ImageReady to convert a layer into a slice, create a 

No Image slice, and create a precisely shaped slice from a selection. Later in the lesson, 

you’ll work with the Rollovers palette—a feature unique to ImageReady—to build inter-

activity into your images.

You’ll start by jumping directly from Photoshop to ImageReady. When you use the 

Jump To feature to go back and forth between Photoshop and ImageReady, the currently 

active file also jumps with you, opening in the target application.

1 In the Photoshop toolbox, click the Jump to ImageReady button ( ).

The 15Start.psd file opens in ImageReady.

2 Choose Window > Workspace > Reset Palette Locations to make sure that the palettes 

are in their default positions. 

Notice that the ImageReady menu bar includes a Slices menu, and that a Slice palette tab 

appears in the Animations palette group in the lower left area of the workspace. This 

menu and palette group appear only in ImageReady, not in Photoshop.

Creating a custom workspace in ImageReady

To prepare for your ImageReady work with slices and rollovers, you’ll streamline the work 

area by closing the palettes you won’t need for these tasks and then resizing and arranging 

the ones you do need. By removing the clutter of unneeded palettes, you maximize your 

efficiency for these types of tasks. You’ll save this arrangement as a custom workspace that 

you can reuse later.

To get a sense of the workspace arrangement you’re aiming for, see the illustration with 

the final steps of this procedure.
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1 Separate the palettes from their default palette groups as follows:

• Drag the Slice palette out of the Animation palette group.

• Drag the Info palette out of the Optimize palette group.

• Drag the Rollovers palette out of its palette group (leaving the Color Table and Layer 

Options palettes together).

• Drag the Layers palette out its palette group (leaving the History and Actions palettes 

together).

2 You won’t be using the following palettes in this lesson, so close them by clicking the 

close button on the palette title bar: the Animation palette group, the Info palette, the 

Color palette group, the Color Table palette group, and the History palette group.

Now just four palettes remain open: the Slice, Rollovers, Layers, and Optimize palettes.

3 Drag the Optimize palette to the upper right corner of your work area, and then open 

the Optimize palette menu and choose Show Options to expand the palette.

4 Drag the Layers palette just below the Optimize palette, and then drag the lower 

right corner of the Layers palette down to increase its height to take advantage of the 

available space.

5 Drag the Rollovers palette to the left of the Optimize palette. Drag its corner so that it 

is as tall as possible.

6 On the Slice palette menu, choose Show Options to expand the palette, and then drag 

it to the lower left corner of the work area.
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Your workspace now includes all the palettes you’ll need to see in this lesson, each 

expanded to the best size for the job.

7 Choose Window > Workspace > Save Workspace. Then, in the Save Workspace dialog 

box, type Rollovers_15, and click OK.

You can now select the Rollovers_15 workspace on the Window > Workspace menu 

whenever you need to use it, such as if your ImageReady session is interrupted before you 

finish this lesson.

Note: The custom workspaces you create and save for either ImageReady or Photoshop are 

not lost when you reset the default preferences for the application. 
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Experimenting with slices created from guides

In Photoshop and ImageReady, you can convert all the areas between guides into user 

slices. When you convert guides into slices, the entire image is sliced and you lose any 

preexisting slices.

1 Choose File > Save, and then choose View > Show > and make sure that checkmarks 

appear by both Slices, Autoslices, and Guides commands. If not, select those commands 

now, as needed.

2 In the toolbox, select the slice select tool ( ), and then select the Designs_button slice 

in the image window.

In the Slice palette, notice that the slice name, URL, Target, and Alt text that you entered 

in Photoshop appear in this ImageReady palette.

3 Choose Slices > Create Slices From Guides.

This is a quick method for creating slices for every rectangular area between the guides.

4 Use the slice select tool to select the Designs_button slice again.

Notice that the options in the Slice palette for the Designs_button slice have changed to a 

default name based on the filename and slice number, and you’ve lost the options you set 

in Photoshop. Because that isn’t what you want to happen, you’ll undo this process.

5 Choose Edit > Undo Create Slices From Guides.

6 Choose View > Show > Guides to deselect the Guides command and hide the guides.
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In Photoshop, you can perform this same task by selecting the slice tool ( ) in the 

toolbox, and then clicking the Slices From Guides button on the tool options bar.

Creating a layer-based slice 

Another method for defining slices in Photoshop and ImageReady is to convert layers into 

slices. A layer-based slice includes all the pixel data in the layer. When you edit the layer, 

move it, or apply a layer effect to it, the layer-based slice adjusts to encompass the new 

pixels. To unlink a layer-based slice from its layer, you can convert it to a user slice.

You’ll create a slice based on the Copyright Strip layer, and then apply a layer effect to it 

so you can see how the slice adjusts to the new effect.

1 In the Layers palette, expand the Copyright Strip layer set and select the Strip 

Background layer.

The Strip Background layer contains the white strip that goes across the bottom of the 

banner.

2 Choose Layer > New Layer Based Slice.

ImageReady replaces the auto slices with one layer-based slice for the entire layer. Notice 

the icon ( ) in the upper left corner of the slice that indicates that the slice is layer-based. 

Note: You can still apply layer styles to the layer that you used to create the layer-based slice. 

The dimensions of the slice automatically increase to accommodate any extra space required 

to show the effect.

3 Choose File > Save to save your work in ImageReady. 
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Creating No Image slices

In ImageReady and Photoshop, you can create No Image slices and add text or HTML 

source code to them. No Image slices can have a background color and are saved as part 

of the HTML file.

The primary advantage of using No Image slices for text is that the text can be edited in 

any HTML editor, saving you the trouble of having to go back to Photoshop or 

ImageReady to edit it. The disadvantage is that if the text grows too large for the slice, 

it will break the HTML table and introduce unwanted gaps.

Now you’ll convert the Copyright Strip slice into a No Image slice and add text to it.

1 Make sure that the layer-based slice that you created for the copyright information is 

selected in the image window.

2 In the Slice palette, choose No Image from the Type pop-up menu.

3 Enter some copyright information for your banner in the Text box. (We used ©2003 

architech art and structure.)

You can add a copyright symbol by pressing Alt+0169 on the numeric keypad (Windows) 

or Option+G (Mac OS).

Because you chose No Image for the slice type, the layer of placeholder text (“place 

copyright info here in slice”) that you do see in ImageReady will not appear in the 

Web page. The text that you typed will appear in the Web page; however, it does not 

appear in your sliced image in ImageReady or Photoshop.

4 In the Layers palette, click the arrow to collapse the Copyright Strip layer set.

5 Choose File > Save.
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Previewing in a Web browser

To make sure that the text you type will fit in the table cell, you’ll preview the image in a 

Web browser.

Note: (Mac OS 10 only) Make sure that you have a Mac OS 10 browser alias in place so that 

the browser doesn’t open in classic mode.

1 In the toolbox, click the Preview In Default Browser button (  or ) or choose a 

browser from the button’s pop-up menu.

The image appears in the browser window, and the HTML source for the preview appears 

in a table below the image. Without pressing the mouse button, move the pointer over the 

buttons.

Note: To add your browser to the Preview In Default Browser button, drag its shortcut 

(Windows) or alias (Mac OS) into the Preview In folder located inside the Helpers folder in 

the Photoshop 7.0 folder.

2 When you’re done previewing the copyright text, quit the browser to return to 

ImageReady.

Creating slices from selections

In ImageReady, the easiest way to create a slice for a small or unusually shaped graphic 

element is to select the element and use the selection as the basis for the slice. This is also 

a useful technique for slicing objects that are crowded closely together. For graphic 

elements that are distinctly colored, the magic wand tool ( ) may be a good choice for 

making the initial selection. In this procedure, you’ll use a keyboard shortcut to select a 

graphic element that is on its own layer.

1 In the Layers palette, expand the Logo layer set.
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2 Hold down Ctrl (Windows) or Command (Mac OS) and select the Big Circle layer. The 

blue circle shape is now selected in the image window.

3 Choose Select > Create Slice from Selection.

Notice the additional auto slices that are created around the logo to complete the table.

4 In the Slice palette, enter the following: In Name, type Logo; in URL, type Team.html; 

and in Alt, type Read about the team. Enter _blank in the Target text box by choosing it 

from the Target pop-up menu.
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5 In the toolbar, make sure that the slice tool or slice selection tool is not selected, or 

select any other tool. 

6 Choose Select > Deselect to remove selection lines from the logo. The slice selection 

border and handles remain selected.

If the slice tool or slice select tool is currently active, the Deselect Slices command appears 

on the Select menu instead of the Deselect command.

7 Choose File > Save.

You can choose URLs that you’ve already entered previously from the URL pop-up menu 

in the Slice palette.

Optimizing slices in ImageReady
ImageReady records separate optimization settings for every slice in the image. 

You specify optimization settings for a slice by selecting it and entering values in the 

Optimize palette. Then, you can save an optimized image file for the selected slice. 

In this part of the lesson, you’ll explore how to set the optimization for slices in 

ImageReady, and then you’ll link the slices together to share the optimization settings.

Setting the optimization for selected slices

Slices use the optimization settings of the entire image until you select them and specify 

new settings. 

1 In the toolbox, select the slice select tool ( ), and then select the number 02 auto slice 

in the image.

2 Click the 2-UP tab in the image window to display the original image next to the 

optimized image.
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3 Choose 200% from the Zoom Level menu in the lower left corner of the image window.

Notice that the quality of the optimized image at its default setting (GIF Web Palette) is 

poor compared to the original image.

4 In the Optimize palette, choose GIF 32 Dithered from the Settings menu.

Now the quality of the selected slice is better than at the default GIF Web Palette setting.

GIF Web Palette setting GIF 32 Dithered setting

5 Examine the optimized image at actual size by choosing 100% from the Zoom Level 

menu. You can click the Toggle Slices Visibility button ( ) in the toolbox to hide the slice 

numbers while you’re viewing the optimized image.

6 In the image, select another auto slice.

In the Optimize palette, notice that the selected slice has the same GIF 32 Dithered 

setting. This is because all auto slices are linked together, and any optimization setting 

that you choose for one auto slice is automatically applied to the others.

7 Choose File > Save.

You’ll save the optimized slices later, after you create some rollovers. For information 

about the optimization settings and available Web formats for your image slices, 

see Lesson 14, “Optimizing Web Images and Image Maps.”

In ImageReady, you can link slices together to share the same optimization settings. Then, 

in ImageReady or Photoshop, you can change the settings for a linked slice and the new 

settings are instantly applied to the entire set of linked slices. Linked sets are color-coded to 

help identify slices in a set.
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Creating rollovers
Rollovers are familiar Web effects. For example, many or even most Web pages feature 

some change in the appearance of a button or hotspot when you move the mouse over it, 

even though you don’t click. This is a typical rollover state.

A rollover state is defined by the event that triggers the rollover behavior, such as a click, 

holding down the mouse (but not clicking), or just moving the pointer over that area of 

the image. For a description of the different rollover states available in ImageReady, see 

the sidebar “Rollover states in ImageReady,” following below.

Secondary rollovers affect the appearance or behavior of other areas of the image when you 

perform the mouse action on the rollover button. 

Only user slices can have rollover states. However, you can promote an auto slice to a user 

slice using the Slices > Promote to user slice command, and then assign rollover states to 

the slice.

Rollover states in ImageReady

When you create a rollover state, ImageReady assigns the type of state by default; however, you can easily 

change the state. You can also use the Rollovers palette to target the image content of a state for editing.

Over Activates the image when the user rolls over the slice or image-map area with the mouse while the 

mouse button is not pressed. (Over is automatically selected for the second rollover state.)

Down Activates the image when the user presses the mouse button on the slice or image-map area. The state 

appears as long as the viewer keeps the mouse button pressed down on the area.

Click Activates the image when the user clicks the mouse on the slice or image-map area. The state appears 

until the user moves the mouse out of the rollover area.

Note: Different Web browsers, or different versions of a browser, may process clicks and double-clicks differ-

ently. For example, some browsers leave the slice in the Click state after a click, and in the Up state after a 

double-click; other browsers use the Up state only as a transition into the Click state, regardless of single- or 

double-clicking. To ensure your Web page will function correctly, be sure to preview rollovers in various Web 

browsers.

Custom Activates the image of the specified name when the user performs the action defined in the corre-

sponding JavaScript code. (You must create JavaScript code and add it to the HTML file for the Web page in 

order for the Custom rollover option to function. See a JavaScript manual for more information.)
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Displaying warped text in the Over state

In the following topics in this lesson, you’ll create several primary and secondary rollover 

effects for various rollover actions. You’ll begin with a rollover for the Over state of the 

Contact button. Your goal is to make the text layer architech appear warped when the 

pointer moves over the Contact button. Because you’ll create this rollover for the Contact 

button and the result will be a change in an area that is outside that slice, it fits the 

definition of a secondary rollover.

1 Click the Original tab in the image window.

2 Using the slice select tool ( ), select the Contact_button slice in the image window. 

Or, select it in the Rollovers palette. In either case, selecting it in one place also selects it 

in the other.

3 In the Rollover palette, click the Create Rollover State button ( ). A new Over State 

rollover appears nested below the Contact_button slice in the palette.

4 In the Layers palette, select the Architech type layer.

5 Select the type tool ( ) to display the text options in the tool options bar, and click the 

Create Warped Text button ( ).

None Preserves the current state of the image for later use, but does not output an image when the file is 

saved as a Web page.

Selected Activates the rollover state when the user clicks the mouse on the slice or image-map area. The state 

appears until the viewer activates another selected rollover state, and other rollover effects can occur while the 

selected state is active.

Out Activates the image when the user rolls the mouse out of the slice or image-map area. (The Normal state 

usually serves this purpose.)

Up Activates the image when the user releases the mouse button over the slice or image-map area. 

–From Adobe Photoshop 7.0 online Help
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6 In the Style pop-up menu in the Warp Text dialog box, choose Bulge. Select Preview 

and wait a moment to see the effect applied to the type. (You may need to move the dialog 

box so you can see the type in the image.) You can try out various values for the different 

Bulge style settings or choose other styles to find a combination that appeals to you. When 

you’re satisfied with a style and settings, make sure they are selected, and click OK.

The Warped Text effect is applied only to the Over state of the button.

Normal state of the Contact button Over state of the Contact button

7 In the Rollover palette, click the Normal state. The word now appears in its undistorted 

condition.

8 Choose File > Save.
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Previewing rollovers in ImageReady

ImageReady provides a quick way to preview rollovers in the image window without 

opening a Web browser. This rollover preview mode in ImageReady is consistent with 

Internet Explorer 5.0 (or later) for Windows. 

1 In the toolbox, select the Toggle Slices Visibility button ( ) to hide the slice 

boundaries.

2 Also in the toolbox, select the Preview Document button ( ).

3 Move the pointer over the Contact button in the image and notice how the Architech 

text changes. Also notice how the selection in the Rollovers palette switches from Normal 

to the Over State below the Contact_button as you move the pointer.

4 Click the Preview Document button again to deselect it. 

5 Click the Toggles Slices Visibility button to show the slice boundaries.

Showing and hiding layers in an Over rollover state

When you previewed the sample finished file in your browser at the beginning of this 

lesson, you saw images that appeared at the left side of the button bar when you moved 

the mouse over those buttons. These are also examples of secondary rollovers for the Over 

state, but this time the change in appearance is caused by tying the visibility of different 

layers to the OverStates of the slices.

1 Using the slice select tool ( ), select the Designs_button slice in the image window.

2 In the Rollover palette, click the Creates Rollover State button ( ) to create an Over 

State for the Designs_button slice.

3 In the Layers palette, select and expand the Image Rollovers layer set. If necessary, click 

to set an eye icon ( ) for the layer set to make it visible.
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4 In the Image Rollovers layer set, click to remove the eye icons ( ) from the For Struc-

tures and For Art layers, as needed, so that the For Designs layer is the only visible layer 

in that layer set.

5 Using the slice select tool, select the Structures_button slice, and repeat steps 3 and 4, 

except this time make the For Structures layer visible and hide the For Designs and For 

Art layers.
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6 Select the Art_button slice and repeat steps 3 and 4 again, but make the For Art layer 

the only visible layer in the Image Rollovers layer set.

7 In the toolbox, select the Toggle Slices Visibility button ( ) and the Preview 

Document button ( ), and move the pointer back and forth across the buttons to see the 

results. Then click those two toolbox buttons again to deactivate them.

8 In the Layers palette, click the small arrow to collapse the Image Rollovers layer set. 

Then choose File > Save. 

Showing and hiding layers in a Down rollover state

Next, you’ll create a Down state for three of the buttons. A Down state is activated when 

the user holds down (but does not release) the mouse button over the slice.

1 Using the slice select tool ( ), select the Designs_button slice in the image window.

2 In the Rollover palette, click the Creates Rollover State button ( ). This time, 

ImageReady automatically creates a Down State for the Designs_button slice.

3 In the Layers palette, select the Architech Highlights layer set, and then click the small 

arrow to expand the layer set. If necessary, click the eye icon ( ) for the layer set to make 

all the layers in it visible in the image window.

Notice the blue text that appears over the word Architech in the image. You’ll hide parts of 

the blue text to draw attention to other parts of the word.
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4 Click the eye icons ( ) next to the bottom four layers to hide the blue highlighting for 

the letters “t-e-c-h.”

Layers hidden in the Down state of the Designs button

The Down state of the Designs button now shows the letters “a-r-c-h-i” in blue and 

“t-e-c-h” in white. 

5 In the Rollovers palette, select the Structures_button slice and then click the New 

Rollover State button ( ) at the bottom of the palette. Then, in the Layers palette, click 

the eye icons in the Architech Highlights layer set so that the letters “a-r-c-h” are hidden 

and the letters “i-t-e-c-h” are visible.

6 Repeat step 5 for the Art_button slice, but this time hide the letters “a-r” and “t” and 

leave all the other layers in the Architech Highlights layer set visible. 

7 In the Rollovers palette, click the Normal rollover state.

8 In the toolbox, select the Toggle Slices Visibility button ( ) and the Preview 

Document button ( ). In the image window, hold down the mouse button as you drag 

the pointer over the three slices. 

9 When you finish previewing, deselect the Toggle Slices visibility and Preview 

Document buttons, and choose File > Save.
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Working with more rollover states
You can improve the usability of your Web pages by adding appropriate navigational hints 

for your readers. In this section, you’ll work on one of the auxiliary pages for the 

Architech Web site and create three different kinds of visual clues to help readers find 

information.

Creating a primary rollover state

So far, all the rollovers you’ve created have been secondary rollovers because the change 

appears outside the slice itself. This time, you’ll create an Over rollover state that directly 

affects the appearance of the slice itself.

1 Choose File > Open, and select the team.psd file in the 

Lessons/Lesson15/15Start/Architech folder. 

The new file is a page describing the Architech team. Some work has already been done 

for you, including the creation of some slices.

2 In the Layers palette, select the Names Glowing layer set, and click the arrow to 

expand it so that you can see the dick glo, jayne glo, and sal glo layers nested in 

the layer set. 
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3 In the Rollovers palette, select the dick_button slice and then click the Create Rollover 

State button ( ) at the bottom of the palette. 

ImageReady creates and selects an Over State rollover under the dick_button slice. 

4 In the Layers palette, under the Names Glowing layer set, click to set an eye icon for the 

dick glo layer so that it is visible. (Leave the jayne glo and sal glo layers hidden.)

5 Repeat steps 3 and 4 for the jayne_button slice, but click an eye icon ( ) in only the 

jayne glo layer, leaving dick glo and sal glo hidden.

6 Again repeat steps 3 and 4 for the sal_button slice, making only the sal glo layer visible 

in the Names Glowing layer set. 

7 Verify your results by selecting the Toggle Slices Visibility button ( ) and the Preview 

Document button ( ) in the toolbar, and then moving the pointer over the three names. 

If you’ve done this procedure correctly, each name glows when the pointer is over it and 

returns to normal view when the pointer moves away from the slice.
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8 In the toolbox, click the Toggle Slices Visibility button ( ) and the Preview Document 

button ( ) again to deselect them.

9 Click the small arrow to collapse the Names Glowing layer set, and choose File > Save.

Creating a Selected rollover state

Ordinarily, users might expect that clicking a hotspot would jump the browser to a linked 

Web page. The Selected rollover state is especially useful when clicking the slice is not 

associated with a different URL.

1 In the Rollovers palette, select the dick_button slice, and click the Create Rollover State 

button ( ) at the bottom of the palette.

ImageReady creates a Down State rollover for the slice.

2 Double-click the new Down State rollover to open the Rollover State Options 

dialog box.

3 In the dialog box, select the Selected option, and click OK.

Now the new rollover shows that it is a Selected State rollover.
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4 In the Layers palette, click the small arrow to expand the Text Blocks layer set. Notice 

the eye icons: The Text Blocks layer set and the Team layer are visible. The other three 

layers are currently hidden.

Note: Although the thumbnails of the layers in the Text Blocks layer set look like identical 

transparent layers, they’re not. Each one contains white text, which is virtually impossible to 

see in these tiny images.

5 Click the eye icon ( ) to hide the Team_text layer, and then click the visibility option 

for the dick_text layer so that an eye icon appears there.

Now the large text block on the right side of the image changes, showing placeholder text 

for a short biography about Dick.

6 Repeat steps 1 through 5 for the jayne_button slice, but make only the jayne_text layer 

visible in the Text Blocks layer set.

7 Again, repeat steps 1 through 5 for the sal_button slice, but make only the sal_text layer 

visible in the Text Blocks layer set.

8 Verify your results by selecting the Toggle Slices Visibility button ( ) and the Preview 

Document button ( ) in the toolbar, and then clicking each of the three name slices. 

Then deselect those two toolbox buttons.

9 Click the small arrow to collapse the Text Blocks layer set, and choose File > Save.
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Adding alternate text

Alternate text appears under two different circumstances: when an image is not shown in 

the browser window, or when the user allows the pointer to hover over a hotspot. Either 

way, taking the trouble to add alternate text adds to the usability of your Web pages. You’ll 

add some alternate text to four slices in the Team.psd image.

1 In the Rollovers palette, select the dick_button slice.

2 In the Alt option in the Slice palette, type Read about Dick, our Chairman.

3 In the Rollovers palette, select the jayne_button slice, and then go to the Alt option in 

the Slice palette and type Read about Jayne, our President.

4 In the Rollovers palette, select the sal_button slice, and then go to the Alt option in the 

Slice palette and type Read about Sal, our Founder.

5 In the Rollovers palette, select the Team_button slice, and then go to the Alt option in 

the Slice palette and type Read about our expert team.

6 Verify your results by selecting the Toggle Slices Visibility button ( ) and the Preview 

Document button ( ) in the toolbar, and then letting the pointer hover for a few seconds 

over each of the four slices. Then deselect those two toolbox buttons.

7 Choose File > Save.
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Previewing the completed pages in a browser
Before you save the optimized image slices, you’ll preview the completed rollovers for the 

banner and team pages in a Web browser. However, the fictitious URL links that you 

assigned to the slices won’t work in Preview In Browser mode, so you’ll test them later 

when you generate the final HTML file and open the file from the browser.

1 Choose Window > Documents > 15Start.psd to switch back to the banner image.

2 In the toolbox, click the Preview In Default Browser button ( ) ( ) or choose a 

browser from the button’s pop-up menu.

3 When the page opens in the browser window, move the pointer over each rollover 

button in the banner.

A different image appears for each of the first three buttons, and the warped text effect 

appears for the last button.

4 Hold the mouse button down when the pointer is over each button.

When you hold down the mouse button: On the Designs button, the white letters “tech” 

are visible; on the Structures button, the white letters “arch” are visible; and on the Art 

button, the white letters “art” are visible. 

5 Click the blue circle in the middle of the image to open the Team.html page.

6 Move the pointer over the dick, jayne, and sal names to verify that the glowing Over 

State is functioning properly.

7 Click each of the four buttons (sal, jayne, dick, and Team) to verify that the Selected 

state is also functioning properly.

8 When you’re finished previewing the rollovers, quit the browser and return to 

ImageReady.
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Saving the sliced images in ImageReady
Now that the banner and team pages are complete, you’ll save the optimized image slices 

and generate an HTML file that contains an HTML table of the sliced image. 

ImageReady also lets you save slices in a cascading style sheet rather than a table. To set 

up the file for cascading style sheets, choose File > Output Settings > HTML. For Slice 

Output, select Generate CSS, and click OK. You can also change the output settings from the 

Save Optimized dialog box.

1 With the 15Start.psd file active, choose File > Save Optimized.

2 In the Save Optimized dialog box, enter Banner.html as the name. On the Format 

pop-up menu, choose HTML and Images, and choose All Slices from the Slices pop-up 

menu. Designate the Lesson/Lesson15/15Start/Architech Pages folder as the location, and 

click Save.

The Replace Files dialog box appears for the four button images you saved earlier in 

Photoshop. 

3 Click Replace to save the new versions of the images.

ImageReady saves the HTML table of the entire sliced image in an HTML file and saves 

the optimized images for all of the auto slices, user slices, layer-based slices, and rollover 

states inside the Images folder. The filenames of the images are based on either the names 

you specified for the slices or the default names and numbers of the slices.

4 Choose Window > Documents > Team.psd to switch to the Team.psd file, and repeat 

steps 1 and 2, but this time enter Team.html as the filename for the saved optimized 

version.
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5 To test the URL links that you assigned to the slices, start a Web browser and use it to 

open the Banner.html file. Again verify the behaviors of the rollover states of the various 

slices, including clicking the blue circle to open the linked Team page and testing the 

behaviors of those rollovers.

6 Close the browser, and then close the files and exit ImageReady and Photoshop.

You have finished your work on Lesson 15. To learn more about using animations with 

your slices and rollovers, see Lesson 16, “Creating Animated Images for the Web.”
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Review questions
1 What are slices?

2 Describe the five ways that image slices are created.

3 What is the advantage of linking slices together?

4 Describe the method for creating a slice with boundaries that exactly encompass a 

small or unusually shaped object.

5 How do you create a slice that contains no image? What purpose would such a 

slice serve?

6 Name two common rollover states and the mouse actions that trigger them. How 

many states can a slice have?

7 Describe a simple way to create rollover states for an image.

Review answers
1 Slices are rectangular areas of an image that you can define in Photoshop or 

ImageReady for individual Web optimization. With slices, you can create animated GIFs, 

URL links, and rollovers.

2 Image slices are created when you define areas in the image using the slice tool, or when 

you convert guides, layers, or selections into slices. They are also created automatically for 

areas in the sliced image that you leave undefined. 

3 The advantage of linking slices together is that they’ll share optimization settings—

if you change the settings for one linked slice, the optimization settings automatically 

change for the other slices in the set.

4 Using the magic wand tool (or another appropriate selection tool) in ImageReady, 

select the object, and choose Slices > Create Slice from Selection.

5 Select the slice with the slice selection tool. In the Slice Options dialog box (Photoshop) 

or Slice palette (ImageReady), choose No Image from the Type menu. No Image slices can 

contain a background color, text, and HTML source code, or they can serve as a place-

holder for graphics to be added later.
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6 Normal and Over. Normal is active in the absence of any mouse action, and Over is 

triggered by moving the pointer over the slice. Selected is another state, which is triggered 

by clicking a slice. There are eight predefined states, counting Custom and None. But 

because you can create your own Custom states, there really is no limit to the number of 

states a slice can have.

7 Using a multilayer image, hide and reveal layers to create different versions of the image 

for each rollover state.


	Adding Interactive Slices and Rollovers
	Getting started
	About slices
	Slicing an image in Photoshop
	Slicing the image in ImageReady
	Optimizing slices in ImageReady
	Creating rollovers
	Working with more rollover states
	Previewing the completed pages in a browser
	Saving the sliced images in ImageReady
	Review questions
	Review answers




