
14 Optimizing Web Images and 
Image Maps

For effective Web publishing, your images 

must strike a good balance between file 

size and display quality. Using Adobe 

Photoshop and Adobe ImageReady, you 

can optimize your images so that they 

have reasonable download times from a 

Web server without losing essential 

details, colors, transparencies, or naviga-

tional elements such as image maps.
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In this lesson, you’ll learn how to do the following: 

• Optimize JPEG and GIF files, and adjust the optimization settings to achieve the 

desired balance between file size and image quality.

• Adjust the amount of dithering applied to an image.

• Define a transparent background for an image.

• Create a hypertext image map.

• Batch-process files to automate the optimization process.

This lesson will take about one and a half hours to complete. The lesson is designed to be 

done in Adobe Photoshop and Adobe ImageReady.

If needed, remove the previous lesson folder from your hard drive, and copy the Lesson14 

folder onto it. As you work on this lesson, you’ll overwrite the start files. If you need to 

restore the start files, copy them from the Adobe Photoshop 7.0 Classroom in a Book CD.

Note: Windows users need to unlock the lesson files before using them. For more information, 

see “Copying the Classroom in a Book files” on page 4.

Optimizing images using Photoshop or ImageReady
Adobe Photoshop and Adobe ImageReady give you an effective range of controls for 

compressing the file size of an image while optimizing its on-screen display quality. 

Compression options vary according to the file format used to save the image.

• The JPEG format is designed to preserve the broad color range and subtle brightness 

variations of continuous-tone images (such as photographs or images with gradients). 

This format can represent images using millions of colors.

• The GIF format is effective at compressing solid-color images and images with areas of 

repetitive color (such as line art, logos, and illustrations with type). This format uses a 

palette of 256 colors to represent the image, and supports background transparency.

• The PNG format is effective at compressing solid-color images and preserving sharp 

detail. The PNG-8 format uses a 256-color palette to represent an image; the PNG-24 

format supports 24-bit color (millions of colors). However, many older browser applica-

tions do not support PNG files.
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In this lesson, you’ll learn how to use Photoshop and ImageReady to optimize and save 

images in JPEG and GIF formats for distribution on the World Wide Web. You’ll work 

with a set of images designed to be used on a fictitious Web site for a virtual zoo.

Photoshop (through its Save For Web dialog box) and ImageReady (through its Optimize 

palette) share many of the same capabilities for optimizing images so that your files are 

small and efficient but still look great. For example, you can use either application to 

select from a wide array of file formats and settings, to suit the goals for your project. You 

can also use either one to compare side-by-side views of different optimized versions of a 

file. Using optimization features and color palettes in either Photoshop or ImageReady, 

you can maximize color integrity while minimizing file size.

Getting started
Before beginning this lesson, restore the default application settings for Adobe Photoshop 

and Adobe ImageReady. See “Restoring default preferences” on page 5.

1 Start Adobe Photoshop.

If a notice appears asking whether you want to customize your color settings, click No.

2 Choose Open > Browse, or click the File Browser tab in the palette well to open it.

3 In the File Browser, use the upper left pane to navigate to the Lessons/Lesson14 folder, 

and select the Lesson14 folder.

Thumbnails of four different Start and End files appear in the right pane, many of which 

appear to be quite similar. You can also select the Photos folder in the Lesson14 folder to 

see the five photographs used to make up the background for the 14Start1.psd file, but 

then select the Lesson14 folder again.
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4 Select the 14Start1.psd thumbnail, so that the thumbnail and metadata for that file 

appear in the left panes of the File Browser. If necessary, resize the File Browser panes to 

enlarge the thumbnail.

This file is a modified version of the zoo map that you will be using later in this lesson. 

This version of the map has been enhanced with scanned photographs of animals, which 

have been further manipulated in Photoshop. In the lower left pane of the File Browser, 

scroll down the metadata and notice that the file size is quite large.

5 Select the 14End1.psd thumbnail. Notice that the file size listed in the metadata is 

dramatically smaller but the image looks about the same as the 14Start1.psd.

6 One by one, select the other numbered Start and End files in the Lesson14 folder to 

preview them.

7 Double-click the file 14Start1.psd to open that file in Photoshop. 
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Optimizing a JPEG image
In this lesson, you will optimize files in both JPEG and GIF formats. You can use either 

Photoshop or ImageReady to compress files in either format. 

Currently, the 14Start1.psd file size is too large for use on a Web page. You’ll compare 

different file-compression formats to see which one gives you the most compression 

without sacrificing too much image quality.

Using the Save For Web dialog box

The Photoshop Save For Web dialog box has all of the optimization capabilities of 

ImageReady. You can compare two or more versions of a file as you work, so that you can 

adjust optimization settings until you have the best possible combination of file size and 

image quality.

1 With the 14Start1.psd file open and active in Photoshop, choose File > Save for Web.

2 In the Save For Web dialog box, click the 4-Up tab to view four versions of the image.

Photoshop automatically generates three different sets of optimization settings, besides 

the original image. Notice the information listed under each view of the image, including 

the file size and the number of seconds required to download the image. The first pane 

shows the original file. The second, third, and fourth panes show different combinations 

of optimization settings for the image, including the file format (such as GIF or JPEG) 

and color-reduction algorithm (such as Selective, Perceptual, or Web). 
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3 In the lower-left corner of the Save For Web dialog box, select 200% or higher from the 

Zoom Level pop-up menu so that you can see the details of the image, and then click the 

preview at the upper right to deactivate the zoom option. 

Compare the preset views of the different optimization settings.

4 Hold down the spacebar, so that the pointer becomes a hand, and drag the image so 

that the Tropical Rainforest text (in the center of the image, over the green parrot) is 

visible in all four views of the image. Again, examine the details closely so that you can see 

the differences among the optimized views.
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Comparing optimized GIF, JPEG, and PNG formats

You can customize any of the optimized views in the Save For Web dialog box. To do this, 

you select one of the optimized image previews, and then select settings for it on the right 

side of the dialog box. By experimenting with different combinations of settings, you can 

get a good idea of which settings will best suit your purpose. 

Before you begin, make sure that the optimized preview at the upper right is selected.

1 In the Settings pop-up menu on the right side of the Save For Web dialog box, select 

GIF 128 Dithered (if it is not already selected).

The information listed below the selected image preview changes.

Notice the dark group of pixels around the text and on the parrot’s beak. (You may need 

to hold down Shift and drag the image again to see the beak.) 

You’ll use the two bottom versions of the image to compare GIF 128 Dithered optimi-

zation with JPEG and PNG optimization.
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2 Click the lower-left version of the image to select it, and select the following JPEG 

options, one at a time, on the Settings pop-up menu:

• JPEG Low. Notice that the image details and text are unacceptably choppy. 

• JPEG High.The image quality improves, but the file size increases significantly.

JPEG Low JPEG High

• JPEG Medium. At this setting, the image quality is acceptable and the file size is lower 

than either the JPEG High version or the GIF version. 

Note: You can select other intermediate levels of quality for JPEG files by typing or dragging 

the Quality slider option on the right side of the Save For Web dialog box.

Now that you’ve tried different GIF and JPEG settings, you’ll use the fourth image preview 

to try another format.

3 Select the lower-right version of the image, and then use the Settings menu to select 

PNG-8 128 Dithered.

Although this results in a smaller file size than the original image, the image quality is not 

as good as the JPEG Medium version, which also has a smaller file size. Furthermore, 

many older browsers cannot read the PNG format. To make this image compatible with 

older browsers, you will save this file for the Web using the JPEG Medium optimization.
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4 Select your JPEG Medium version of the optimized image (in the lower-left corner of 

the dialog box), and then select the Progressive check box.

Note: When Progressive is selected, any download of the image occurs in several passes, each 

of which increases the image quality.

The Progressive JPEG download

5 Click Save. In the Save Optimized As dialog box, use the default name 14Start1.jpg, 

and save the file in the same folder as the original Photoshop file.

6 Choose File > Close, and don’t save your changes.

Optimizing a GIF image
Now you’ll optimize a flat-color image in GIF format and compare the results of different 

palette and dither settings. Although you could do this entire section in Photoshop, you’ll 

use ImageReady.

Photoshop and ImageReady share many features, but some tasks are more appropriately 

done in one application or the other, depending on your intended use of the image file. 

Certain tasks can be done only in Photoshop and others only in ImageReady. For these 

reasons, both applications include convenient ways to jump from one to the other.

If you have an open file when you jump from Photoshop to ImageReady or vice versa, the 

file opens in the application that you jump to. If you have more than one file open, only 

the active file opens in the other application when you jump. If no files are open, you can 

still jump back and forth from one application to the other. 
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Preparing an ImageReady workspace

Before you begin working on a new file, you’ll jump from Photoshop to ImageReady and 

then define an ImageReady workspace for the tasks you’ll do in this section.

1 In Photoshop, click the Jump To ImageReady button ( ) at the bottom of the 

toolbox to switch from Photoshop to ImageReady.

Note: If you do not have enough memory to run both applications simultaneously, quit 

Photoshop and then start ImageReady.

2 In ImageReady, choose Window > Workspace > Reset Palette Locations to make sure 

that all palettes are in their default positions.

3 Drag the tabs of the following palettes out of their palette groups to separate them as 

stand-alone palettes:

• The Info palette (from the Optimize palette group).

• The Color Table palette (from the Rollovers palette group). 

4 Click the close boxes in the following palette groups to hide these palettes:

• The Color palette group (the Color, Swatches, and Styles palettes).

• The Info palette.

• The Rollovers palette group (the Rollovers and Layer Options palettes).

5 Drag the Optimize, Color Table, and Layers palette groups to rearrange them in your 

work area as needed, and resize them to take advantage of the available space.

6 Choose Window >Workspace > Save Workspace.

7 In the Save Workspace dialog box, type Optimize_14, and click OK.



423ADOBE PHOTOSHOP 7.0
Classroom in a Book

The Optimize_14 workspace option now appears on the Window > Workspace menu, 

named to help you remember that you created this workspace in Lesson 14 for work with 

optimizing. You can reset your workspace to this configuration of palettes or go back to 

the default workspace at any time by choosing the one you want to use on the Workspace 

submenu.

Choosing basic optimization settings in ImageReady

Earlier in this lesson, you used Photoshop optimization settings that were integrated into 

the Save For Web dialog box. In ImageReady, the same options appear in the Optimize 

palette. 

1 In ImageReady, choose File > Open, and open the file 14Start2.psd from the 

Lessons/Lesson14 folder.

This image was created in Adobe Illustrator, and then rasterized into Photoshop format. 

The image contains many areas of solid color.

2 Click the 2-Up tab in the image window.

The optimized version of the image is selected on the right side of the window.

3 In the Settings pop-up menu on the Optimize palette, choose GIF 128 No Dither.
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4 In the Color Reduction Algorithm menu, select Perceptual.

Selecting a color reduction algorithm

One of the ways to reduce image file size is to reduce the number of colors in the image. Photoshop can 

calculate the most needed colors for you, based on any of several available algorithms. You specify which 

algorithm is used by making a selection from the Color Reduction Algorithm menu, which includes the 

following options:

Perceptual Creates a custom color table by giving priority to colors for which the human eye has greater 

sensitivity. 

Selective Creates a color table similar to the Perceptual color table, but favors broad areas of color and the 

preservation of Web colors. This color table usually produces images with the greatest color integrity. Selective 

is the default option.

Adaptive Creates a custom color table by sampling colors from the spectrum appearing most commonly in 

the image. For example, an image with only the colors green and blue produces a color table made primarily 

of greens and blues. Most images concentrate colors in particular areas of the spectrum.

Web Uses the standard 216-color color table common to the Windows and Mac OS 8-bit (256-color) 

palettes. This system ensures that no browser dither is applied to colors when the image is displayed using 

8-bit color. (This palette is also called the Web-safe palette.) If your image has fewer colors than the total 

specified in the color palette, unused colors are removed. 

Custom Preserves the current color table as a fixed palette that does not update with changes to the image.

Windows or Mac OS Uses the system’s default 8-bit (256-color) color table, which is based on a uniform 

sampling of RGB colors. If your image has fewer colors than the total number specified in the color palette, 

unused colors are removed.

–From Adobe Photoshop 7.0 online Help
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The status bar at the bottom of the image window displays the view magnification and 

other useful information about the original and optimized versions of the image. 

A. File size and download time of optimized image 
B. File sizes of original and optimized images

You can customize the type of information that appears here.

5 In the status bar, choose Image Dimensions from the pop-up menu on the right.

This option displays the size of the image in pixels, which is important when planning 

how to fit an image into a predesigned Web-page template.

Exploring the Color Table

The Color Table palette displays the colors that the currently selected color reduction 

algorithm uses for the currently active file—in this case, the colors that the Perceptual 

option selects for the zoo map image. The colors appear to be listed in random order in 

the palette.

The total number of colors is listed at the bottom of the palette. You can resize the palette 

or use the scroll bar to view all the colors. You can also change how the colors are arranged 

in the palette.

A B



LESSON 14426
Optimizing Web Images and Image Maps

In the Color Table palette, a few of the colors have a tiny white diamond shape at the 

center of the swatch. These diamonds indicate that those colors are Web-safe.

1 On the Color Table palette menu, choose Sort By Hue, and notice how the 

arrangement of the color swatches changes.

2 In the Optimize palette, choose Web from the Color Reduction Algorithm menu.

Notice that the color changes in the image and in the Color Table palette, which updates 

to reflect the Web palette.

3 Experiment by selecting different optimize options and notice the effects on the image 

and on the Color Table palette.

4 When you finish experimenting, re-enter the settings you had earlier: GIF 128 

No Dither and Perceptual. (You can leave the colors sorted any way: unsorted, by hue, by 

luminance, or by popularity.) 
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Reducing the color palette

To compress the file size further, you can decrease the total number of colors included in 

the Color Table palette. A reduced range of colors will often preserve good image quality 

while dramatically reducing the file space required to store extra colors.

1 Make sure that the optimized version of the image is selected, zoom is 200% or higher, 

and that Perceptual is selected in the Optimization palette. Notice the current file size.

2 Hold down the spacebar and drag the image so that at least parts of the words Tropical 

Rainforest and some of the blue Northern Wilderness area appear in the image area.

For the Web: Viewing hexadecimal values for colors in the Info palette

In Photoshop, hexadecimal values for colors are displayed in the Info palette when you select Web Color mode 

for one or both color readouts. In ImageReady, hexadecimal values for colors are displayed automatically in 

the right side of the Info palette, next to RGB color values. The Photoshop and ImageReady Info palettes also 

display other information, depending on the tool being used. 

To view hexadecimal color values in the Photoshop Info palette:

1. Choose Window > Info or click the Info palette tab to view the palette.

2. Choose Palette Options from the Palette menu.

3. Under First Color Readout, Second Color Readout, or both, choose Web Color from the Mode menu.

4. Click OK.

The Info palette displays the hexadecimal equivalents for the RGB values of the color beneath the pointer in 

the image.

–From Adobe Photoshop 7.0 online Help
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3 In the Colors option in the Optimize palette, type or select 32 from the pop-up menu.

Notice the significant reduction in the file size, but that the quality of the image is so much 

lower that some details, such as some animal silhouettes, have been lost or compromised. 

Locking colors to preserve image details

In the previous procedure, you saw how reducing the number of colors compromised 

details in the illustrations. Specifically, by reducing the number of colors from 128 to 32, 

several animal silhouettes changed color and some animals disappeared altogether 

because the new color assigned to them was also the color assigned to the background 

behind them.

You’ll now learn how to lock specific colors to ensure that those colors do not drop out of 

the reduced palette.

1 In the magnification pop-up menu of the image window, select 100% so that you can 

see most of the image.

2 In the Optimization palette, change the Colors value back to 128.

3 Select the eyedropper tool ( ), and click the camel silhouette in the African Savannah 

area to sample that color.

The dark brown color is selected in the Color Table palette.
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4 Click the Lock button ( ) at the bottom of the Color Table palette to lock the 

selected color. 

A small square appears in the lower-right corner of the color swatch, indicating that the 

color is locked. 

Note: To unlock a locked color, select the color swatch and then click the Lock button again.

5 Using the eyedropper tool and the Lock button on the Color Table palette, select and 

then lock the dark blue color of the bear silhouette in the Northern Wilderness area. 

6 In the Optimize palette, reduce the number of colors to 32.

Notice that the locked colors remain in the palette after the reduction and in the image. 

However, new color-shift problems appear: The trail in the Northern Wilderness area is 

now the same color as its background, and the Tropical Rainforest animals are now brown 

instead of dark green.

7 In the Optimize palette, change the number of colors back to 128.

8 Again using the eyedropper and the Color Table Lock button, select and lock the colors 

of the parrot in the Tropical Rainforest and both the trail and background colors in the 

Northern Wilderness. You now have five locked colors.

9 In the Optimize palette, set the colors to 32. 

10 Choose File > Save.

If you experiment with optimization of image files, you’ll notice that significant image 

degradation can occur when the palette is reduced below 32 colors. In fact, for all but the 

simplest images, even 32 colors may be too drastic a reduction. For the best file 

compression of a GIF image, try to use the fewest number of colors that will still display 

the quality you need.

For an illustration of the image set to different palette values, see figure 14-1 in the 

color section.
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Controlling dither
You may have noticed that certain areas of the image appear mottled or spotty when 

optimized with different color palettes and numbers of colors. This spotty appearance 

results from dithering, the technique used to simulate the appearance of colors that are 

not included in the color palette. For example, a blue color and a yellow color may dither 

in a mosaic pattern to produce the illusion of a green color that is not included in the color 

palette.

When optimizing images, keep in mind the two kinds of dithering that can occur:

• Application dither occurs when ImageReady or Photoshop attempts to simulate colors 

that appear in the original image but not in the optimized color palette you specify. You 

can control the amount of application dither by dragging the Dither slider in the 

Optimize palette.

• Browser dither can occur in addition to application dither. A browser dither occurs 

when a Web browser using an 8-bit (256-color) display simulates colors that appear in the 

optimized image’s color palette but not in the system palette used by the browser. You can 

control the amount of browser dither by shifting selected colors to Web-safe colors in the 

Color Table palette.

In the Photoshop Save For Web dialog box and in ImageReady, you can view application 

dither directly in an optimized image. You can also preview the additional browser dither 

that will appear in the final image when viewed in a browser using an 8-bit display.

Controlling application dither

Dithering creates the appearance of more colors and detail, but it can also increase the file 

size of the image. The Dither option controls the range of colors that ImageReady 

simulates by dithering. For optimal compression, use the lowest percentage of application 

dither that still provides the color detail you require.

1 If necessary, open the 14Start2.psd file and zoom in to 200% or higher.

2 Make sure that the optimized version of the image is selected, and that the Optimize 

palette is set to GIF format, Perceptual, and 32 colors. Notice the blocky drop shadows 

below the text.
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3 In the Optimize palette, enter the following options:

• Select Diffusion as the dithering algorithm (to replace No Dither).

• Drag the slider or type to set 100% as the Dither value.

Using a combination of different colors, ImageReady tries to simulate the colors and 

tonalities that appear in the original image but not in the 32-color palette. Notice the 

speckled pattern that replaces the blocky drop shadows below the text. While not ideal, 

this pattern is a significant improvement and is acceptable. The dithered green 

background color for the Tropical Rainforest, however, is not acceptable.

4 Drag the Dither slider to 50%, and then experiment with other dither percentages.

ImageReady minimizes the amount of dither in the image, but no percentage of dither 

will preserve the drop shadows without ruining the green background.

For an illustration of the effects of different dither percentages on an image, 

see figure 14-2 in the color section.

5 Set the dither back to 100%. 

6 Change the number of colors back to 128.

7 Use the eyedropper tool ( ) to select the green background in the Tropical Rainforest, 

and then click the Lock button ( ) in the Color Table palette to lock that color. In the 

Optimize palette, switch the Colors value back to 32.

8 In the image window, change the magnification back to 100%.

Although the difference may seem subtle, the image is now acceptable.
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Minimizing browser dither

As you learned earlier, images that include non–Web-safe colors undergo a process of 

dithering when displayed in a Web browser using an 8-bit display, because the browser 

simulates colors that do not occur in the 8-bit system palette. From ImageReady, you can 

preview how an optimized image will look when dithered in a Web browser. 

To protect a color from browser dither, you can Web-shift the color, converting the color 

to its nearest equivalent in the Web palette. Because the Web palette includes the subset 

of colors that appear in both the Windows and the Mac OS system palettes, Web palette 

colors will display without dithering in browsers on either platform. 

1 With the optimized 14Start2.psd image open, choose View > Preview > Browser Dither 

(so that a checkmark appears next to the command).

Notice that browser dither occurs in the brown African Savannah background. You’ll 

Web-shift that color to reduce the amount of browser dither in the image.

Note: If you don’t see the dithering, increase the zoom to about 300% or turn off the browser 

dither preview and then turn it back on to observe the effects. You can toggle the browser 

dither preview off and on by pressing Ctrl+Shift+Y (Windows) or Command+Shift+Y 

(Mac OS). 

2 Select the eyedropper tool ( ) and click anywhere in the dithered brown background. 

The sampled color appears selected in the Color Table palette.
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3 Click the Web-shift button ( ) at the bottom of the Color Table palette.

The swatch changes position in the palette and a small diamond appears in the center of 

the swatch, indicating that it has been shifted to its nearest Web-palette equivalent.

By Web-shifting the brown background, you change its color to one that can be displayed 

without dithering by a Web browser on a 256-color system.

4 Choose File > Save.

Note: In Photoshop 7.0 and ImageReady 7.0, you can also quickly map one color to another 

color or to a transparency. This remapping reassigns all the pixels that appeared in the 

selected color to the new color or transparency. For more information, see Adobe 

Photoshop 7.0 online Help.

Specifying background transparency
Background transparency lets you place a nonrectangular graphic object against the 

background of a Web page; the areas outside the borders of the object are defined as trans-

parent, letting the Web-page background color show through. You can specify 

background transparency for GIF and PNG images.

Converting the Background into an ordinary layer

Before you can use the GIF file format’s ability to preserve transparency, you must create 

some transparency in your image. You’ll do that by removing the white backdrop 

surrounding the image map. To start this process, you’ll first convert the Background 

layer to a regular layer. 

1 Make sure that the 14Start2.psd file is open in ImageReady.

2 Select the Original tab at the top of the image window.



LESSON 14434
Optimizing Web Images and Image Maps

3 Choose Fit on Screen from the Zoom Level menu in the lower left corner of the image 

window.

4 On the Layers palette menu, choose Layer Options. Without changing the default 

settings (including the name, Layer 0), click OK. The layer now appears in the Layer 

palette as Layer 0. 

A Background layer cannot contain any transparency information because, by definition, 

there is nothing behind it to be seen. If you tried to use one of the techniques that usually 

can replace colored pixels with transparent ones, the results would be that the original 

pixels would be changed to the currently selected background color instead of becoming 

transparent pixels.

Using the magic wand tool to create transparency

In this part of the lesson, you’ll use the magic eraser tool to quickly convert the backdrop 

color of the zoo map to transparent pixels.

The magic eraser tool erases all pixels of a particular color with a single click. You’ll use 

this tool to erase all of the white pixels in the layer. However, you only want to erase the 

white pixels outside of the zoo map (not the white of the lettering), so you will first create 

a selection that excludes the interior portion of the image.
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1 Select the rectangular marquee tool ( ).

2 Draw a rectangular selection marquee so that it includes all the text in the five colored 

regions of the zoo map, as shown in the illustration below.

3 Choose Select > Inverse to select everything outside of the rectangular selection 

marquee.

4 Select the magic eraser tool ( ), hidden under the eraser tool ( ).

5 In the tool options bar, deselect the Contiguous option so that all white pixels in the 

selection will be erased, including each isolated white section within the leaves.

6 Click the white background outside of the zoo map.

Now all the white backdrop is gone, replaced by transparency so that you can see the 

checkerboard pattern behind the image.
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Preserving and previewing transparency

Now you will confirm that the transparent areas in the image will be included as trans-

parent pixels in the optimized GIF file. Then, you’ll preview the transparency in your 

browser.

Because the ImageReady preview feature displays the image on a Web page with a white 

background, you’ll change the matte color of the image so that you can see the trans-

parency.

1 On the Optimize palette, make sure that the Transparency check box is selected. (If you 

don’t see that check box, choose Show Options on the Optimize palette menu.)

Selecting Transparency converts areas in the original image with less than 50% opacity to 

background transparency in the optimized image. 

2 Choose Select > Deselect, and then choose File > Save.

3 Click the Matte swatch in the Optimize palette to open the color picker, and then select 

any color except white. Click OK to close the color picker.
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4 Choose File > Preview In, and choose a Web browser from the submenu.

Note: To use the Preview In command, you must have a Web browser installed on 

your system.

If it is not already open, the browser first starts and then displays the optimized image in 

the upper-left corner of the browser window. The browser also displays the pixel dimen-

sions, file size, file format, and optimization settings for the image, along with the HTML 

code used to create the preview.

Transparency option selected Transparency option deselected

5 Quit your browser when you’re done previewing the image.
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Trimming extra background areas

Although the background of the zoo-map image now contains transparent pixels that do 

not display, these pixels still take up file space, adding to the size of the image. You can 

trim away unneeded background areas to improve the layout of the image and optimize 

the file size.

1 In ImageReady, choose Image > Trim.

The Trim command lets you crop your image, according to the transparency or pixel 

color of the extra border area.

2 In the Trim dialog box, select Transparent Pixels if it is not already selected, and 

click OK.

ImageReady trims the extra transparent areas from the image.

3 Choose File > Save Optimized As. 

4 In the Save Optimized As dialog box, use the default name (14Start2.gif), and 

click Save. 

5 In the Replace Files dialog box, click Replace (if it appears).

6 Choose File > Close.

You will be prompted to save the 14Start2.psd file before closing. Since you are finished 

with this file for the lesson, there is no need to save the last changes.
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Creating a dithered transparency
In this section, you’ll create a dithered transparency for a graphic that will serve as the 

entry point from another Web page to the zoo map. By creating a dither from an opaque 

drop shadow to transparency, you’ll make it possible to create a smooth transition from 

the image to any color backdrop on the page without having to redo any work.

You’ll do this in two procedures. First, you’ll apply a drop shadow to the image. Then, 

you’ll add dithering to the drop shadow so that it blends into a background color for the 

Web page.

You can do this procedure in Photoshop or do it in ImageReady using the same controls 

but in slightly different locations.

Adding a drop shadow

The file you’ll be working on is intended to serve as the “entry” button on the portal page 

to the zoo Web site. You’ll add a drop shadow to the button to make the image appear to 

float above the background, emphasizing that it is an interactive element of the page.

1 Choose File > Open, and select the 14Start3.psd file in the Lessons/Lesson14 folder.

2 In the Layers palette, click the Add A Layer Style button ( ) at the bottom of the 

palette, and then select Drop Shadow from the pop-up menu.

3 In the Layer Style dialog box (Photoshop) or the Drop Shadow palette (ImageReady), 

enter the following values:

• For Distance, drag the slider or type 15.

• For Spread, drag the slider or type 7%.

• For Size, drag the slider or type 15.
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4 (Photoshop only) Click OK to close the Drop Shadow dialog box.

5 Choose File > Save.

Adding transparency dithering to the drop shadow

As you’ve already learned, dithering is a method of creating gradations of color with a 

limited color palette. This makes it useful for Web pages because you can simulate 

smoother gradations without sacrificing small file size and quick downloads.

1 With the 14Start3.psd active, choose File > Save for Web to open the Save for Web 

dialog box. (This step is not necessary in ImageReady.)

2 Click the Optimized tab in the Save for Web dialog box (Photoshop) or image window 

(ImageReady).

3 On the right side of the Save for Web dialog box (Photoshop) or in the Optimize palette 

(ImageReady), set the following options:

• In the Settings pop-up menu, select GIF 128 Dithered.

• Select the Transparency check box, if it is not already selected. 

Note: In ImageReady, if you do not see the Transparency check box, open the Optimize palette 

menu and choose Show Options, or click the double-arrows ( ) on the Optimize tab to 

expand the palette so that you can see all the options.
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• In the pop-up menu below the Transparency check box, select Diffusion Transparency 

Dither.

• In the Amount option, use the pop-up slider or type 55%. 

Save For Web dialog box Optimize palette
(Photoshop) (ImageReady)

4 Click the Matte swatch to open the color picker. Select any color other than white, and 

click OK. (We selected a light brown: R=220, G=190, B=150.)

To see the effect of the matte setting, try zooming in so that you can see individual pixels 

in the dither—about 400% or higher. Notice that the pixels closest to the edge of the green 

area are black and that the others become increasing more blended with the matte color 

as they occur farther from the edge. Then zoom back to 100%.

5 At the bottom of the Save For Web dialog box, click the button with the browser icon, 

or click the arrow to select your browser from the pop-up menu. (In ImageReady, use the 

Preview In Default Browser button in the toolbox to open the file in a browser.)



LESSON 14442
Optimizing Web Images and Image Maps

6 In the browser, notice how the drop shadow blends against the background matte 

color. When you finish viewing your document, close the browser or switch back to 

Photoshop (or ImageReady). 

7 Click the Save button in the Save for Web dialog box. (In ImageReady, choose File > 

Save Optimized.)

8 In the Save Optimized As dialog box, accept the default settings and filename 

(14Start3.gif) and save the file in your Lessons/Lesson14 folder. 

9 Choose File > Save to save the 14Start3.psd file, or close the file without saving.

Working with image maps (ImageReady)
An image map is an image that contains multiple hypertext links to other files on the Web. 

Different areas, or hotspots, of the image map link to different files. Adobe ImageReady 

creates client-side image maps and server-side image maps.

Creating image maps is one of the functions that you must do in Adobe ImageReady. You 

can use Photoshop to create slices, which share certain functionality with image maps, 

but you cannot create image maps with Photoshop.

Note: For information about slicing an image into multiple image files and linking each slice 

to another Web page, see Lesson 15, “Adding Interactive Slices and Rollovers.”
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Using layers to create image maps

In this procedure, you’ll create an image map in an existing image. You define hotspots 

using layers or one of the image-map tools. Then you’ll assign each hotspot to an URL, 

linking it to a site on either a local computer or the World Wide Web.

You’ll use a version of the zoo-map image that places each colored region on its own layer. 

You’ll convert each layer to an image-map hotspot. By using layers to define the hotspots, 

you easily gain control over the shapes of those areas. 

1 In ImageReady, choose File > Open, and open the file 14Start4.psd from the 

Lessons/Lesson14 folder.

2 In the Settings menu on the Optimize palette, choose GIF 64 Dithered.

3 In the Layers palette, select the African Savannah layer.

Creating and viewing image maps (ImageReady)

Image maps enable you to link an area of an image to a URL. You can set up multiple linked areas—called 

image map areas—in an image, with links to text files; other images; audio, video, or multimedia files; other 

pages in the Web site; or other Web sites. You can also create rollover effects in image map areas. 

The main difference between using image maps and using slices to create links is in how the source image is 

exported as a Web page. Using image maps keeps the exported image intact as a single file, while using slices 

causes the image to be exported as a separate file. Another difference between image maps and slices is that 

image maps enable you to link circular, polygonal, or rectangular areas in an image, while slices enable you 

to link only rectangular areas. If you need to link only rectangular areas, using slices may be preferable to 

using an image map. 

Note: To avoid unexpected results, do not create image map areas in slices that contain URL links—either 

the image map links or the slice links may be ignored in some browsers.

–From Adobe Photoshop 7.0 online Help
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4 Choose Layer > New Layer Based Image Map Area. 

A ghosted rectangular area surrounded by a red line appears, enclosing the entire African 

Savannah portion of the image. This red line and ghosting define the hotspot area 

included in the image map.

5 In the Animation palette group, click the Image Map tab, and choose Polygon from the 

Shape pop-up menu. (You can also open the Image Map palette by choosing Window > 

Show Image Map.) 

Now the red outline approximates the shape of the savannah area.

6 In the Quality option on the Image Map palette, drag the slider or type 90 to make the 

red line more closely conform to the savannah area shape.

Now that you’ve defined the hotspot area, you can link it to another file in your Web site 

or to a different location on the Web. For the purposes of this lesson, you’ll link your 

hotspots to fictitious URLs for the zoo.

7 In the URL option in the Image Map palette, type the fictitious address of a Web site, 

http://www.adobe.com/african_savannah.html, in the URL text box.
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In the Layers palette, a pointing-finger icon now appears on the African Savannah layer, 

indicating that the layer has a layer-based image map.

Note: If you prefer, you can use other URLs for this exercise, linking the hotspots to your own 

local intranet pages or to some of your favorite sites on the World Wide Web.

8 (Optional) For more practice with image maps, select the other four areas of the zoo 

map (Exotic Asia, Tropical Rainforest, Himalayan Highlands, and Northern Wilderness) 

and, one layer at a time, repeat steps 3 through 7 to create more layer-based image maps. 

Use the same settings, but change the “african_savannah” part of the URLs, replacing it 

with the name of the layer used to create the image map.

Don’t worry now about any mistakes you might make when you type in your URLs. You’ll 

learn how to edit image-map information later, in “Creating the HTML file and editing 

image-map information” on page 447.

9 Choose File > Save.

Adjusting the cross-platform gamma range

Before you take your final steps to publish your image-mapped illustration of the zoo 

image on your network or the Web, you’ll verify whether or not the brightness of your 

image is compatible across monitors on different platforms. Machines running Windows 

generally display a darker midtone brightness, or gamma, than Macintosh machines. 

Note: Before starting this part of the lesson, be sure to calibrate your monitor so that it 

displays color accurately. For information, see Lesson 17, “Setting Up Your Monitor for Color 

Management.”
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1 In the ImageReady toolbox, click the Toggle Image Maps Visibility button ( ) to hide 

the polygon boundary lines of the image-map areas.

2 Choose View > Preview > and then choose a command as follows, to preview the image 

as it will appear on the platform you’re not using:

• If you are working in Windows, choose Standard Macintosh Color. 

• If you are working in Mac OS, choose Standard Windows Color.

3 Choose Image > Adjustments > Gamma.

4 Click the appropriate button:

• If you are working in Windows, click Windows to Macintosh, and then click OK. 

• If you are working in Mac OS, click Macintosh to Windows, and then click OK.

5 Choose File > Save Optimized As.

6 In the Save Optimized As dialog box, choose Images Only from the Format menu, 

use the default name 14Start4.gif, and click Save.

Now you’ll preview your image map in a Web browser.

7 Choose File > Preview In, and choose a browser application from the submenu.
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8 In the browser window, move the pointer over the different zoo regions, and notice 

that these elements contain hypertext links. If you had a modem and an Internet 

connection and if these were authentic URLs, you could click the hotspots to jump to the 

specified page of the zoo site. 

9 Quit your browser to return to Adobe ImageReady.

Creating the HTML file and editing image-map information

When you save an image map in an HTML file, the basic HTML tags needed to display 

the image on a Web page are generated automatically. The easiest way to do this is simply 

to choose the HTML and Images Format option when you save the optimized image.

Once you have created the HTML file, it can easily be updated to reflect any changes, such 

as new or modified image-map areas or URLs. 

1 In ImageReady, choose File > Save Optimized As.

Note: In Photoshop, you create an HTML file in the Save Optimized As dialog box that 

appears after optimizing the image and clicking OK in the Save For Web dialog box.

2 In the Save Optimized As dialog box, select the HTML and Images option on the Save 

As Type pop-up menu (Windows) or the Format menu (Mac OS). Use the default name 

14Start4.html, and save the file in your Lessons/Lesson14 folder.

If the Replace Files dialog box appears, click Replace.
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When you select the HTML and Images option, an HTML page containing the image is 

saved automatically, in addition to the graphic file. This HTML file will have the same 

name as the image, but with the .html extension.

Now you’ll use ImageReady to change one of the URL links and update the HTML file.

3 In the toolbox, select the image map select tool ( ), hidden under the rectangle image 

map tool ( ).

4 In the image window, click to select the African Savannah image-map area.

5 In the Image Map palette, change the URL to http://www.adobe.com/newafrica.html.

If you have other image-map information that you want to edit, use the image map select 

tool to select the image-map areas that you want to update, and then enter your changes 

in the Image Map palette options.

6 When you finish making changes, choose File > Update HTML.

7 In the Update HTML dialog box, select the 14Start4.html file, and click Open. Then 

click Replace when the Replace Files dialog box appears and click OK to dismiss the 

update message.

8 Choose File > Close to close the image. Don’t save changes, if prompted.
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You can use your Web browser to open and view 14Start4.html. You can also open the file 

in a text editor, or a word-processing or HTML editing program to make your own 

revisions to the HTML code.

Batch-processing file optimization
ImageReady supports batch-processing through the use of droplets—icons that contain 

actions for ImageReady to perform on one or more files. Droplets are easy to create and 

use. To create a droplet, you drag the droplet icon out of the Optimization palette and 

onto the desktop. To use a droplet, you drag a file or folder over the droplet icon on the 

desktop.

1 In ImageReady, choose File > Open, and open any file in the Lessons/Lesson14/Photos 

folder.

2 Experiment with different file formats and other settings in the Optimize palette as 

desired until you are satisfied with the result. 

We used JPEG, High quality (60), and Progressive.

For the Web: HTML File-Naming Conventions

Use the UNIX® file-naming convention, because many network programs truncate (shorten) long filenames. 

This convention requires a filename of up to eight characters, followed by an extension. Use the .html or .htm 

extension. 

Do not use special characters such as question marks (?) or asterisks (*), or spaces between the letters in your 

filename—some browsers may not recognize the pathname. If you must use special characters or spaces in 

the filename, check with an HTML editing guide for the correct code to use. For example, to create spaces 

between letters you will need to replace the space with “%20”.
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3 Drag the droplet icon ( ) out of the Optimize palette and drop it anywhere on your 

desktop. (If you are using Windows, you may have to resize the ImageReady window to 

make your desktop visible.)

4 Close the file (without saving it).

5 From your desktop, drag the Photos folder from the Lessons/Lesson14 folder and drop 

it onto the droplet to batch-process the photographic images within the folder.

ImageReady optimizes each file and adds the Web image to the Photos folder.

6 Open any of the Web image files in the Photos folder. 

Notice that they have all been optimized according to the settings specified when the 

droplet was created.

7 Quit ImageReady when you are done.
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Review questions
1 For image optimization, what are the advantages of using ImageReady rather than 

Photoshop?

2 What is a color table?

3 When does browser dither occur, and how can you minimize the amount of browser 

dither in an image?

4 What is the purpose of assigning matte color to a GIF image?

5 Summarize the procedure for creating an image map.

Review answers
1 There aren’t really any advantages to using one application over the other for 

optimization. Both Photoshop and ImageReady can perform a wide range of image-

optimization tasks. ImageReady has many Web-specific features that you won’t find in 

Photoshop, but image optimization is not one of them.

2 A color table is a table that contains the colors used in an 8-bit image. You can select 

a color table for GIF and PNG-8 images, and add, delete, and modify colors in the 

color table.

3 Browser dither occurs when a Web browser simulates colors that appear in the image’s 

color palette but not in the browser’s display system. To protect a color from browser 

dither, you can select the color in the Color Table palette, and then click the Web-shift 

button at the bottom of the palette to shift the color to its closest equivalent in the Web 

palette. 

4 By specifying a matte color, you can blend partially transparent pixels in an image with 

the background color of your Web page. Matting lets you create GIF images with 

feathered or anti-aliased edges that blend smoothly into the background color of your 

Web page. But, with ImageReady 7.0, you can also specify a dither to transparency.

5 To create an image map, you define hotspot areas of the image using the image-map 

tools or by selecting layers and choosing Layer > New Layer Based Image Map Area. Then 

you use the Image Map palette to define the shape of the hotspot and link each hotspot to 

a URL address.
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